After upgrade to SuseLinux 15.2 hp laserjet p1102w will not print

Asked by jd Rose

I upgraded suse linux from 15.1 to 15.2. the printer will not print on 15.2
I downloaded and reloaded files from HP and deleted and reloaded printing packs from linux and
the problem persists.

After trying for a few days I decides to start over.
My system has two hard drives, one for the OS and one for data. I reformatted the A hard drive
loaded 15.1 and upgraded to 15.2. I still have the same problem the printer will not print.

The two hard drives mentioned above were installed to replace the two originals that were on the same computer.
Prior to removal, the two originals were also upgraded from 15.1 to 15.2, and the printer worked.

I removed the newer hard drives, from the computer, ( those that will not print) and reinstalled the two original hard drives,
and the printer prints as it always has, it works fine.

When I try to print the print window shows"HP LaserJet Professional p 1102w, hpcups 3.19.12, requires proprietary plugin".
I can also choose CUPS-PDF which does nothing. However, I can choose "print to file (PDF)" which will send the file where ever
I send it.

I have tried to print from root and also as a user from a desktop built on drive A, thinking that it may be a path problem but the results were the same, no printing.

If anyone that can point me in a direction other than buying another printer or buying two new hard drives I would appreciate the help.

I downloaded the current hp-plugin, from and ran it from Desktop.
I get the following
Invalid MIT-COOKIE-1 key and
the hp-device manager setup window opens
USB button is on
choose "Continue" and get
Error: no device is found on USB
I can check "Show Advanced Options"
then check Manual Discovery, then check "Next".
Results, "No devices found."

Also, from a command line in Desktop, I can type "hp-setup". and
get the same "hp-device manager setup window".
The results of using hp-setup are the same , "No devices found."

I built this system by downloading minimal system for suse 15.1 then,
when upgrading the system to 15.2 I chose to load KDE
The second time I built the system I checked the hardware information
in the setup window before proceeding to upgrade to 15.2, and the printer was listed.

I think that there files missing from the upgrade. I may rebuild a third time but
choose to load 15.1 which will include KDE in the first install then choose to upgrade to 15.2
including KDE or I may choose to install all of KDE which may take less time.

I have a "hp-officejet 4315 all in one" which when plugged in is found and setup as expected, but
the laserjet is another story.

This problem is solved.
I reloaded Drive a with v. 15.1 and got it to print by installing hpcups 3.18.6 which requires proprietary plugin. The proprietary plugin was downloaded when an HP window opened and asked if I wanted to download it and install it now, which I did. The printer was now printing in v. 15.1.

Once the printer worked in v. 15.1, I then upgraded to v. 15.2.
After v. 15.2 was loaded, I checked the printer installation and found that hpcups 3.18.6 was still installed. I tried to print and got the same HP window saying that this printer requires proprietary plugin and asked if I wanted to download it and install it now?
After the plugin download and installed, the printer worked as expected. This setup was a no-brainer thanks to HP.

The upgrade from v. 15.1 to 15.2 did not change the driver (no complaints) it is still 3.18.6. However during the upgrade, the plugin was deleted and had to be re-installed.
Thanks to all that responded.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

"hpcups 3.19.12, requires proprietary plugin"

Try downloading the plugin installer in the version fitting to your hplip installation from and install it with


Revision history for this message
Manfred Hampl (m-hampl) said :

Don't confuse the installer for the HPLIP software and the installer for the plugins (with "-plugin" in its name)

Can you help with this problem?

Provide an answer of your own, or ask jd Rose for more information if necessary.

To post a message you must log in.