HP LaserJet CM1415fn does not scan with HPLIP 3.20.11 caused by checksum error when downloading

Asked by Rolf on 2021-03-19

Hi,

I tried to use the scanner of my HP LaserJet CM1415fn multi function printer on Linux Mint 20.1. When starting XSane or hp-scan I'm asked for a Driver Plugin Installation of a proprietary HP plug in. Clicking on Next I'm asked to download it from an HP authorized server. Clicking again on next the download happens and ends with an error message from HP Device Manager - Plugin Installer: "/home/miro/.hplip/hplip-3.20.11-plugin.run file does not match its checksum. File may have been corrupted or altered"
By Clicking on OK - the only choice I have the error message: "Failed to install Plug-in. Either you have chosen to skip the Plug-in installation or entered incorrect Password." appears.
I have this issue on Fat Clients as well as on virtual machines. - So it seems to be general problem.
Could you fix it, please so that scan functionality of HP LaserJet CM1415fn is available again. The scan functionality worked fine under Linux Mint 19.3.

Kind regards
Rolf

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2021-04-07
Last query:
2021-04-07
Last reply:
2021-04-05
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Rolf (rolf-blattner) said : #2

The Problem still exists

Best Manfred Hampl (m-hampl) said : #3

You can manually download the plugin installer from https://developers.hp.com/hp-linux-imaging-and-printing/plugins
Download the run file with the version number identical to your HPLIP installation (in your case probably 3.20.11) and install it with
sh hplip-3.20.11-plugin.run

If this fails the same way, then you might try installing HPLIP and the plugin in version 3.21.2

Rolf (rolf-blattner) said : #4

Installation with sh hplip-3.20.11-plugin.run still produced an error: "Error importing HPLIP modules. Is HPLIP installed?
". - But the file was downloaded so I tried to install it via the software again - this time not the recommended way; I used the downloaded file, was asked for a password and then - it was installed successfully. -- Thank you for your help.