Driver for HP LaserJet Pro MFP M28a

Asked by Ulrike Schnoor on 2021-02-07

Hello,

I am trying to install the HP LaserJet Pro MFP M28a on a Ubuntu 18.04 system connected via USB (and detected by lsusb). It shows up in the Printers section of the System Settings, but printing fails with "Filter failed". So I tried to install it with hplip.
According to the table in [1], the driver should be available from HPLIP 3.18.4 onwards. I have tried to run hplip 3.20.11 in order to install this, but there are two issues:
- I do not see the driver in the directory I would expect it: hplip-3.20.11/ppd/hpijs/hp-laserjet_pro_mfp_m*
- When I run sh hplip-3.20.11.run, it does not compile:
Running 'make'
Please wait, this may take several minutes...
error: 'make' command failed with status code 2

Thanks for any pointers how to solve any of those problems,
Ulrike

[1] https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Ulrike Schnoor
Solved:
Last query:
Last reply:
Ulrike Schnoor (ulrike-sch) said : #1

I solved this issue by going into the directory and running the compilation directly:
hplip-3.20.11 > python3 install.py

Now it is printing.