Can't print on photo paper to Smart Tank Plus 555 in Debian

Asked by Pim Blokland on 2021-02-02

On a machine with Debian 10.7, hplip refuses to use photo paper as a media type.

I am using hplip 3.20.9, which I had to install from the buster-backports, since the version that came with Debian 10.7 was too old to recognise the HP Smart Tank Plus 555.

Now I'm sure the printer can do photo paper, because I connected it to a Windows machine and it works fine there. But hplip says no.
If I run printer management in the browser (though localhost:631) and try to set HP Photo Papers, it says "The following options are conflicting: Media size A4; Media type HP Photo Papers" and won't allow it.
And if I go to print properties in the standard print dialog of any application, the choice for photo paper isn't even there: it only lists plain and matte papers.

So am I doing something wrong? Or is this a bug in hplip 3.20.9?

(I tried using the plain or matte setting for printing to photo paper, but that didn't work out: the ink won't dry. This is normal, apparently, but knowing that doesn't help me with the problem.)

Edit: solved. I connected the printer via Wifi to the router, and although HP Device Manager does not see the printer any more, I could connect to it with the web interface at localhost:631. Then it turned out the error about conflicting options was gone.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Pim Blokland
Last query:
Last reply:
brian_p (claremont102) said : #1

I am disinclined to debug HPLIP but there is another way to use
the device. My treatment depends on having a wireless connection
and knowing what you get fot

  avahi-browse -rt _ipp._tcp


  avahi-browse -rt _uscan._tcp

avahi-browse is in the avahi-utils package.

Pim Blokland (mr-lister-sir) said : #2

Sorry, it's a desktop computer which does not have Wifi. Also, neither of the avahi-browse commands return anything.

brian_p (claremont102) said : #3

Ok, USB connected then. What I have in mind is still possible. In fact,
it is provided by default on Debian 11.

Go to

and install ipp-usb. Re-plug the device, execute

  systemctl status ipp-usb

and , if that service is active, try the avahi-browse commands again.

Pim Blokland (mr-lister-sir) said : #4

@brian_p Thanks for your help so far!
But are you sure ipp-usb is fully compatible with Debian 10.7? I installed it from the site you mentioned, but dpkg said:

Setting up ipp-usb (0.9.17-1+48.1) ...
/usr/sbin/policy-rc.d returned 101, not running 'start ipp-usb.service'

Now I was able to start it manually, using systemctl start ipp-usb.service, but I'm not sure if that helped.
After that, the two commands you mentioned about still have no output, and neither does ipp-usb udev.
systemctl status ipp-usb says:

● ipp-usb.service - Daemon for IPP over USB printer support
   Loaded: loaded (/lib/systemd/system/ipp-usb.service; static; vendor preset: enabled)
   Active: active (running) since Tue 2021-02-02 19:20:39 CET; 1min 1s ago
     Docs: man:ipp-usb(8)
 Main PID: 10346 (ipp-usb)
    Tasks: 12 (limit: 4915)
   Memory: 12.3M
   CGroup: /system.slice/ipp-usb.service
           └─10346 /sbin/ipp-usb udev

but I have no idea if that helps. All I see is that ipp-usb is running. So I don't know what more info you need.
I did see that sudo ipp-usb check says:

IPP over USB devices:
 Num Device Vndr:Prod Model
   1. Bus 001 Device 006 03f0:1a54 "HP Smart Tank Plus 550 series"

So it can see the printer. But how can I proceed from here?

brian_p (claremont102) said : #5

> After that, the two commands you mentioned about still have no output,

Have you installed, as advised, avahi-utils?

Pim Blokland (mr-lister-sir) said : #6

Yes. Otherwise the computer would have said command not found when trying to run ahavi-browse, or am I missing something?

brian_p (claremont102) said : #7

> Yes. Otherwise the computer would have said command not found when
> trying to run ahavi-browse, or am I missing something?

Correct, Pim.

I have done this dozens of times and have also checked for typos. How about

  avahi-browse -art



Pim Blokland (mr-lister-sir) said : #8

Yes, sorry for the typo. (I checked my command history and I didn't have the same typo there.)
avahi-browse -art also has no output. If I add the v flag it says

E Ifce Prot Name Type Domain
: Cache exhausted
: All for now

Is that normal? I don't know what I'm supposed to be looking for.

driverless also outputs nothing.

brian_p (claremont102) said : #9

> avahi-browse -art also has no output.

Apologies for leading you along this path unnecessarily. I completely
forgot that ipp-usb requires a version of avahi-daemon greater than the
one on Debian 10. See

Pim Blokland (mr-lister-sir) said : #10

I've also been searching elsewhere, and there are many sites that tell me installing the printer wirelessly is much less cumbersome that via USB.
Now I've been ignoring that until now, because the computer doesn't have Wifi, but I know the printer has. And my router does provide Wifi, so I went through the motions of connecting the printer to the router, just to see what would happen.

And sure enough, the computer can find the printer in the network, and I can choose any kind of paper type I want, and it works great.
(That is, with the USB cable unplugged, HP Device Manager can no longer see the printer, but the web interface at localhost:631 can, so I can configure it from there.)

So, thanks for your help. Maybe you think you didn't do much, but you did make me look up things I hadn't thought of looking up before, which sent me in the right direction!

brian_p (claremont102) said : #11

Glad you got things going, Pim. Now do want some good news?

It *is* possible to use ipp-usb on Debian 10! Would you mind testing?
It might help other users.

 * To make it more convincing, disconnect the printer from the network.
 * In /etc/ipp-usb/ipp-usb.conf change the "interface" line to have

                                interface = all

 * Re-plug the printer and try the previous commands.