hplip No module named 'PyQt4.sip'

Asked by Gotit on 2021-01-14

Dist: Arch/Antergos
Printer: HP_LaserJet_100_colorMFP_M175nw
$ hp-check -t
/usr/bin/hp-check:685: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if 'getfacl' not in g and '' is not g and 'file' not in g:
Saving output in log file: /home/steve/Desktop/hp-check.log

HP Linux Imaging and Printing System (ver. 3.20.11)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

warning: antergoslinux distro is not found in AUTH_TYPES
warning: 24- version is not supported. Using 24-8.04.1 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.10.6-arch1-1 #1 SMP PREEMPT Sat, 09 Jan 2021 18:22:35 +0000 GNU/Linux
 Host: Asus405
 Proc: 5.10.6-arch1-1 #1 SMP PREEMPT Sat, 09 Jan 2021 18:22:35 +0000 GNU/Linux
 Distribution: 24
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.11
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 24 distro version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.20.11

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.20.11
html=/usr/share/doc/hplip-3.20.11
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.11
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.20.11

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 01/14/21 16:55:09
version = 3.20.11

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups CUPS - Common Unix Printing System REQUIRED 1.1 2.3.3 OK 'CUPS Scheduler is running'
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.53.3 OK -
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.31 OK -
 dbus DBus - Message bus system REQUIRED - 1.12.20 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.118 OK -
 network network -wget OPTIONAL - 1.21.1 OK -
 avahi-utils avahi-utils OPTIONAL - 0.8 OK -

------------------------
| General Dependencies |
------------------------

 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.3.3 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 2.3.3 OK -
 libpthread libpthread - POSIX threads library REQUIRED - b'2.32' OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 sane SANE - Scanning library REQUIRED - 1.0.31 OK -
 sane-devel SANE - Scanning library development files REQUIRED - 1.0.31 OK -
 libavahi-dev libavahi-dev REQUIRED - - OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.9 OK -
 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 OK -
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.9.1 OK -
 python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
Traceback (most recent call last):
  File "/usr/bin/hp-check", line 862, in <module>
    num_errors, num_warns = dep.validate(time_flag, is_quiet_mode)
  File "/usr/bin/hp-check", line 367, in validate
    self.__update_deps_info(supported_distro_vrs, dep,
  File "/usr/bin/hp-check", line 210, in __update_deps_info
    installed_ver = self.core.version_func[deps_info[6]]()
  File "/usr/share/hplip/installer/dcheck.py", line 303, in get_pyQt4_version
    from PyQt4 import QtCore
ModuleNotFoundError: No module named 'PyQt4.sip'

The issue is that install will not complete due to the last line above.
I've installed (several times) Python3 PyQt4
I have this directory /usr/share/sip/PyQt4/

What else do I need to do to make hplip recognize that I have 'PyQt4.sip'??

Note: I have this issue on 2 machines that have been running with hplip for 2 years.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Gotit
Solved:
Last query:
Last reply:
Gotit (sca957) said : #1

I resolved the issue by commenting all the pyqt4 lines in:
/usr/share/hplip/installer/dcheck.py
/usr/share/hplip/installer/core_install.py

This forced the scripts to use pyqt5.

After that, I was bitten by this bug:
https://bugs.launchpad.net/hplip/+bug/1910146

Fortunately, the bug also carries a fix! So, I can print and scan remotely again.