hplip driver: HP MFP 126 scanner not enabled in Debian 10.7

Asked by SHIVSHANKAR SASTRY on 2021-01-12

I installed Debian 10.7 some days ago in place of an unstable Ubuntu 20.04. I downloaded and installed the HP driver, but the message was explicit in saying that Debian is supported only up to version 10.6. Sure enough, the printer worked, but not the scanner, which I need. The printer works by default anyway with drivers bundled with Debian. But I need the scanned to work.
Printer model HP LaserJet Pro MFP M126nw

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
shivani mandora
Solved:
2021-01-14
Last query:
2021-01-14
Last reply:
2021-01-13
brian_p (claremont102) said : #1

Install the plugin.

SHIVSHANKAR SASTRY (bennedose) said : #2

I have Debian 10.7
The installer give the following message:
 Failed to load module "canberra-gtk-module"
error: debian-10.7 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.6 version packages."

Installation does not enable the scanner

Best shivani mandora (shivani1708) said : #3

Hi ,

Debian 10.7 is still not supported by HPLIP.
It will be part of next release.

SHIVSHANKAR SASTRY (bennedose) said : #4

Thanks shivani mandora, that solved my question.

StephenBruce (stephenbruce) said : #5

I’ve ordered coursework at https://jetwriting.com/ service. Well, the order was completed quite fast. The prices are affordable for most students. The writer I was dealing with was very friendly and professional. The book review he has done is perfect. Such a great service and affordable pricing! The final paper requires no further proofreading or corrections. I am sure our paths will cross once again in the nearest future.