LaserJet CP1025 color on Ubuntu 20.10 don't works

Asked by Luiz Portella on 2021-01-11

Hello, I try some ways, but Hp-print don't works...

luiz@txu:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 003: ID 05c8:036e Cheng Uei Precision Industry Co., Ltd (Foxlink) Webcam
Bus 001 Device 002: ID 03f0:112a HP, Inc HP LaserJet CP 1025
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

luiz@txu:~ $ sudo hp-setup
[sudo] senha para luiz:

HP Linux Imaging and Printing System (ver. 3.20.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

Done.

luiz@txu:~ $ uname -a
Linux txu 5.8.0-36-generic #40~20.04.1-Ubuntu SMP Wed Jan 6 10:15:55 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Print's status is "Rendering completed"... I send print, job's status "Filter failed"

After new reboot I get: No system tray detected on this system.
Unable to start, exiting.

Thanks a lot!

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2021-01-11
Last reply:
2021-01-13
Luiz Portella (lujz-br) said : #2

After edit file /usr/share/hplip/data/models/models.dat like Ahronovitz (lanatol) wrote in https://bugs.launchpad.net/hplip/+bug/1907444 "sudo hp-setup" finds printer....

I get this installed, status "ready to print", but i send job... and get window :
Driver Plug-in installation

An additional driver plug-in is required to operate this printer. You may download the plug-in directly from an HP authorized server (recommended), or, if you already have a copy of the file, you can specify a path to the file (advanced).

I click "next" for ge from net, but i don't get it... What file is it?

Thanks!

Luiz Portella (lujz-br) said : #3

I run "hp-doctor" and I did not access to

$ ll /etc/cups/ppd/HP_LaserJet_CP_1025.ppd
-rw-r----- 1 root lp 15K jan 11 14:21 /etc/cups/ppd/HP_LaserJet_CP_1025.ppd

So: $ sudo adduser luiz lp

Reboot both notebook and printer. I sill can't print: "An additional driver plug-in is required to operate this printer. You may download... "

I found http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/
I get http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.20.11-plugin.run (I use hplip 3.20.11) ... After many times trying. I run it, without errors.

If i try print, i don't get request about plugin, but the job was stopped ... Filter failed". In hp-doctor I read:
Checking for HP Properitery Plugin's....
No plug-in printers are configured.

I remove the printer, add it by hp-setup and can't print.... Somebody can help me?

shivani mandora (shivani1708) said : #4

Hi,

Your issue is based in below bug:

We will fix it in our next HPLIP release. Please wait till then.

https://bugs.launchpad.net/hplip/+bug/1907444

Can you help with this problem?

Provide an answer of your own, or ask Luiz Portella for more information if necessary.

To post a message you must log in.