Ubuntu20.04 - hplip-3.12.6 - Give a couple of errors when i do make.

Asked by Maria Rama Diumenj├│ on 2021-01-06

Hello, today I've bought an HP printer and i tried to do the software installation.
I have Ubuntu 20.04, then I downloaded hplip-3.12.6.tar.gz. I have followed every step in this web ( https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/distros/ubuntu ).

First error, in step 2, when I run command "sudo apt-get install --assume-yes libcups2 cups libcups2-dev cups-bsd cups-client libcupsimage2-dev libdbus-1-dev build-essential ghostscript openssl libjpeg62-dev libsnmp-dev libtool libusb-1.0-0-dev wget python-imaging policykit-1 policykit-1-gnome python-qt4 python-qt4-dbus python-dbus python-gobject python-dev python-notify python python-reportlab libsane libsane-dev sane-utils xsane", i have problems because i think python-qt4 packet and the relacionated don't exist, so I have qt5 and I have python3, but i don't understand why this commands don't work in my terminal.

The second error is that when i do make, in step 5 ( the step 4, ./configure, works well), appears 2 errors in cupsext.c.

Please, could you help me? Without this I can't install de software for my new printer and I will have to come it back. Maybe there is an easy way to install the hp software in ubuntu, but i don't know it.

Thank you,

Maria.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2021-01-06
Last reply:
2021-01-06
Manfred Hampl (m-hampl) said : #1

Downloading the tar.gz file is the wrong approach.

If you are running Ubuntu, then you should install the pre-packaged version from the Ubuntu repositories with the command (to be executed in a terminal window)

sudo apt install hplip-gui

Can you help with this problem?

Provide an answer of your own, or ask Maria Rama Diumenj├│ for more information if necessary.

To post a message you must log in.