Ubuntu 18 HPLIP cannot detect printer Laser 100 series

Asked by Leopoldo Agorio on 2020-11-13

Just got printer HP Laser 100 series, configured it with a Windows PC, was able to print via Wi-Fi, and was also able to print with smartphone device via Wi-Fi
I followed the instructions in https://developers.hp.com/hp-linux-imaging-and-printing/gethplip to install hplip, and now can pop up the client by typing hp-setup.
In the "HP Device Manager - setup" when i select "Network/Ethernet/Wireless network (direct connection or JetDirect)" i get the following error message:

HPLIP cannot detect printers in your network. This may be due to existing firewall settings blocking the required ports.
                When you are in a trusted network environment, you may open the ports for network services like mdns and slp in the firewall. For detailed steps follow the link.
                 http://hplipopensource.com/node/375 "

Link doesn't seem to work. I also tried selecting "Show Advanced Options"->"Manual Discovery" and typing in the IP Adress of the printer but obtained the same error.

Any ideas on how to fix?

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
brian_p (claremont102) said :

> Any ideas on how to fix?

The HP Laser 100 series is not supported by HPLIP. See



Revision history for this message
brian_p (claremont102) said :

> Any ideas on how to fix?

Actually, Leopoldo, I have a much better solution for you. It seems you have
the device on the network. Give the outputs of

  avahi-browse -rt _ipp._tcp
  avahi-browse -rt _uscan._tcp


Can you help with this problem?

Provide an answer of your own, or ask Leopoldo Agorio for more information if necessary.

To post a message you must log in.