Device Mgr v15.0 (HPLIP v3.20.9) won't delete printers

Asked by SaintDanBert on 2020-11-12

My Linux Mint 19.3 repos edition of HPLIP would not connect to my new, Officejet-9010-Pro.
I fetched and installed v3.20.9 for Mint from online. I tried to delete/remove the 9010 because its IP address changed on my LAN and I could not alter the IP without delete/remove.

Issue #1
=======
HPLIP does not delete/remove that device. In the icon view, the 9010 appears with a red-X emblem. My 8600 does too, but it is offline while we remodel the home office.

QUESTION -- Must a printer be connected and online before HPLIP can delete/remove the device?

Issue #2
=======
QUESTION -- v3.20.9 does not apprear to have an "HPLIP Toolbox" utility or a separate applet for the tray indicator.

Issue #3
=======
Even though I ask for the Tray Indicator to appear all the time, I never see it using v3.20.9 and Cinnamon v4.4.8.

Thanks in advance,
~~~ 0;-Dan

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-12-01
Last reply:
2020-11-19

This question was reopened

shivani mandora (shivani1708) said : #1

Hi ,

Please find my comments inline:

Issue #1
=======
HPLIP does not delete/remove that device. In the icon view, the 9010 appears with a red-X emblem. My 8600 does too, but it is offline while we remodel the home office.

QUESTION -- Must a printer be connected and online before HPLIP can delete/remove the device?
No. You can remove the printer even if it is not online.

Issue #2
=======
QUESTION -- v3.20.9 does not apprear to have an "HPLIP Toolbox" utility or a separate applet for the tray indicator.
You can see tray utility from print settings of hp-toolbox.

Issue #3
=======
Even though I ask for the Tray Indicator to appear all the time, I never see it using v3.20.9 and Cinnamon v4.4.8.
Do you mean systray ?

I get nothing in the SYSTRAY! Period!
==========
prompt$ screenfetch -n

OS: Mint 19.3 tricia
 Kernel: x86_64 Linux 5.4.0-54-generic
 Uptime: 6d 3h 57m
 Packages: 3092
 Shell: bash 4.4.20
 Resolution: 1366x768
 DE: Cinnamon 4.4.8
 WM: Muffin
 WM Theme: Mint-X-Orange (Cinnamox-Gold-Spice)
 GTK Theme: Mint-X-Orange [GTK2/3]
 Icon Theme: Mint-X-Orange
 Font: Ubuntu 10
 CPU: Intel Core i5-2520M @ 4x 3.2GHz
 GPU: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2)
 RAM: 2944MiB / 7844MiB
==========

"HP System Tray Service" appears in the "Startup Applications" dialog from the "Preferences" menu.

Can you help with this problem?

Provide an answer of your own, or ask SaintDanBert for more information if necessary.

To post a message you must log in.