Can no longer print on Linux Mint 19.3

Asked by George Sophy on 2020-11-05

Very recently (less than two weeks), I can no longer print to an HP Laserjet CM1312 MFP from Linux Mint 19.3. I have HPLIP version 3.20.9 installed.

When a print job is sent to the printer, the job will stop and I've seen evidence that the CUPS filter service stopped.

I've also seen a recent article that certs for HP drivers were revoked under MacOS and looking for some validation or help to see if this might be related to the issue under MacOS.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
George Sophy
Solved:
2020-11-05
Last query:
2020-11-05
Last reply:

This question was reopened

George Sophy (tomato-one) said : #1

I've solved this problem. It has nothing to do with the HPLIP drivers.

The PDF files that I'm trying to print have garbage characters in the document's metadata title. If I open a PDF document and look at the document's properties, the title says...
"Asdfj ;lasdjf ;lasjdf lasdjf l;a f;lasj flja sdf;l jaslf jas;lf j;lasdjf ;lkasjd fl;kasjdf l;kjas fl;ja;fl a;sklj f;lkas jf;lkas jfl;kas dfl;kjda fl;kjasdlkf jasdl;kf jlk;asd fjl;kasdj fl;kasdj flk;asdj l;fkjasd lfkj a;sdklf lksdj fl;asdj f;lasd f;lk adf"

I used exiftool to change the document's title and was able to print successfully.

Marking this solved.