Laser Jet Pro MFP M28-M31 Driver

Asked by Daniel Boone on 2020-11-04

Operating System: Linux Mint 18 Cinnamon 64-bit
Cinnamon Version 3.0.7
Linux Kernel 4.4.0-193-Generic
Processor: Intel Core i5 CPU M 520 @ 2.4GHz x 2

Printer HP Laser Jet Pro MFP M28-M31

hp-check.log
=============================================================
hp-check[11179]: info: :
hp-check[11179]: info: :HP Linux Imaging and Printing System (ver. 3.16.7)
hp-check[11179]: info: :Dependency/Version Check Utility ver. 15.1
hp-check[11179]: info: :
hp-check[11179]: info: :Copyright (c) 2001-15 HP Development Company, LP
hp-check[11179]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[11179]: info: :This is free software, and you are welcome to distribute it
hp-check[11179]: info: :under certain conditions. See COPYING file for more details.
hp-check[11179]: info: :
hp-check[11179]: info: :Note: hp-check can be run in three modes:
hp-check[11179]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper
hp-check[11179]: info: :dependencies are installed to successfully compile HPLIP.
hp-check[11179]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
hp-check[11179]: info: :has the proper dependencies installed to successfully run.
hp-check[11179]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).
hp-check[11179]: info: :
hp-check[11179]: info: :Check types:
hp-check[11179]: info: :a. EXTERNALDEP - External Dependencies
hp-check[11179]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[11179]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[11179]: info: :d. [All are run-time checks]
hp-check[11179]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[11179]: info: :
hp-check[11179]: info: :Status Types:
hp-check[11179]: info: : OK
hp-check[11179]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[11179]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[11179]: info: :
warning: 22-18 version is not supported. Using 22-17.3 versions dependencies to verify and install...
hp-check[11179]: info: :
hp-check[11179]: info: :---------------
hp-check[11179]: info: :| SYSTEM INFO |
hp-check[11179]: info: :---------------
hp-check[11179]: info: :
hp-check[11179]: info: : Kernel: 4.4.0-193-generic #224-Ubuntu SMP Tue Oct 6 17:15:28 UTC 2020 GNU/Linux
 Host: dev-ltdboone-us
 Proc: 4.4.0-193-generic #224-Ubuntu SMP Tue Oct 6 17:15:28 UTC 2020 GNU/Linux
 Distribution: 22 18
hp-check[11179]: info: : Bitness: 64 bit

hp-check[11179]: info: :
hp-check[11179]: info: :-----------------------
hp-check[11179]: info: :| HPLIP CONFIGURATION |
hp-check[11179]: info: :-----------------------
hp-check[11179]: info: :
hp-check[11179]: info: :HPLIP-Version: HPLIP 3.16.7
hp-check[11179]: info: :HPLIP-Home: /usr/local/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 22 distro 18 version
hp-check[11179]: info: :
hp-check[11179]: info: :Current contents of '/etc/hp/hplip.conf' file:
hp-check[11179]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.16.7

[dirs]
home=/usr/local/share/hplip
run=/var/run
ppd=/usr/local/share/ppd/HP
ppdbase=/usr/local/share/ppd
doc=/usr/local/share/doc/hplip-3.16.7
html=/usr/local/share/doc/hplip-3.16.7
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/local/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.16.7
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no

hp-check[11179]: info: :
hp-check[11179]: info: :Current contents of '/var/lib/hp/hplip.state' file:
hp-check[11179]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[11179]: info: :
hp-check[11179]: info: :Current contents of '~/.hplip/hplip.conf' file:
hp-check[11179]: info: :[installation]
date_time = 11/04/2020 17:10:55
version = 3.16.7

hp-check[11179]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[11179]: info: :
hp-check[11179]: info: :--------------
hp-check[11179]: info: :| COMPILEDEP |
hp-check[11179]: info: :--------------
hp-check[11179]: info: :
hp-check[11179]: info: : gcc gcc - GNU Project C and C++ Compiler REQUIRED - 5.4.0 OK -
hp-check[11179]: info: : make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
hp-check[11179]: info: : error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
hp-check[11179]: info: :
hp-check[11179]: info: :------------------------
hp-check[11179]: info: :| General Dependencies |
hp-check[11179]: info: :------------------------
hp-check[11179]: info: :
hp-check[11179]: info: : libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 OK -
hp-check[11179]: info: : python-xml Python XML libraries REQUIRED - 2.1.0 OK -
hp-check[11179]: info: : libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
hp-check[11179]: info: : sane-devel SANE - Scanning library development files REQUIRED - 1.0.25 OK -
hp-check[11179]: info: : pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
hp-check[11179]: info: : pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.4 OK -
hp-check[11179]: info: : libpthread libpthread - POSIX threads library REQUIRED - 2.23 OK -
hp-check[11179]: info: : python-devel Python devel - Python development files REQUIRED 2.2 2.7.12 OK -
hp-check[11179]: info: : cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.1.3 OK -
hp-check[11179]: info: : python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.0 OK -
hp-check[11179]: info: : cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
hp-check[11179]: info: : reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.3.0 OK -
hp-check[11179]: info: : pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
hp-check[11179]: info: : libusb libusb - USB library REQUIRED - 1.0 OK -
hp-check[11179]: info: : cups-image CUPS image - CUPS image development files REQUIRED - 2.1.3 OK -
hp-check[11179]: info: : python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.12 OK -
hp-check[11179]: info: : python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[11179]: info: : libjpeg libjpeg - JPEG library REQUIRED - - OK -
hp-check[11179]: info: : sane SANE - Scanning library REQUIRED - 1.0.25 OK -
hp-check[11179]: info: :
hp-check[11179]: info: :----------------------
hp-check[11179]: info: :| Scan Configuration |
hp-check[11179]: info: :----------------------
hp-check[11179]: info: :
hp-check[11179]: info: : scanext Scan-SANE-Extension REQUIRED - 3.16.7 OK -
hp-check[11179]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.16.7 OK 'hpaio found in /etc/sane.d/dll.conf'
hp-check[11179]: info: :
hp-check[11179]: info: :-------------------------
hp-check[11179]: info: :| External Dependencies |
hp-check[11179]: info: :-------------------------
hp-check[11179]: info: :
hp-check[11179]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -
hp-check[11179]: info: : cups CUPS - Common Unix Printing System REQUIRED 1.1 2.1.3 OK 'CUPS Scheduler is running'
hp-check[11179]: info: : network network -wget OPTIONAL - 1.17.1 OK -
hp-check[11179]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.25 OK -
hp-check[11179]: info: : policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
hp-check[11179]: info: : xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
hp-check[11179]: info: : dbus DBus - Message bus system REQUIRED - 1.10.6 OK -
hp-check[11179]: info: : avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -
hp-check[11179]: info: :
hp-check[11179]: info: :---------------------
hp-check[11179]: info: :| Python Extentions |
hp-check[11179]: info: :---------------------
hp-check[11179]: info: :
hp-check[11179]: info: : hpmudext IO-Extension REQUIRED - 3.16.7 OK -
hp-check[11179]: info: : cupsext CUPS-Extension REQUIRED - 3.16.7 OK -
hp-check[11179]: info: :
hp-check[11179]: info: :------------------------------
hp-check[11179]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[11179]: info: :------------------------------
hp-check[11179]: info: :
hp-check[11179]: info: :No Scanner found.
hp-check[11179]: info: :
hp-check[11179]: info: :--------------------------
hp-check[11179]: info: :| DISCOVERED USB DEVICES |
hp-check[11179]: info: :--------------------------
hp-check[11179]: info: :
hp-check[11179]: info: :No devices found.
hp-check[11179]: info: :
hp-check[11179]: info: :---------------------------------
hp-check[11179]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[11179]: info: :---------------------------------
hp-check[11179]: info: :
hp-check[11179]: info: :
hp-check[11179]: info: :HP-HP-LaserJet-MFP-M28-M31
hp-check[11179]: info: :--------------------------
hp-check[11179]: info: :Type: Unknown
hp-check[11179]: info: :Device URI: dnssd://HP%20LaserJet%20MFP%20M29w%20(794E2D)._ipp._tcp.local/?uuid=564e4233-5236-3637-3534-842afd794e2d
hp-check[11179]: info: :PPD: /etc/cups/ppd/HP-HP-LaserJet-MFP-M28-M31.ppd
warning: Failed to read /etc/cups/ppd/HP-HP-LaserJet-MFP-M28-M31.ppd ppd file
hp-check[11179]: info: :PPD Description:
hp-check[11179]: info: :Printer status: printer HP-HP-LaserJet-MFP-M28-M31 is idle. enabled since Wed 04 Nov 2020 04:58:46 PM EST
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
hp-check[11179]: info: :
hp-check[11179]: info: :
hp-check[11179]: info: :--------------
hp-check[11179]: info: :| PERMISSION |
hp-check[11179]: info: :--------------
hp-check[11179]: info: :
hp-check[11179]: info: :
hp-check[11179]: info: :-----------
hp-check[11179]: info: :| SUMMARY |
hp-check[11179]: info: :-----------
hp-check[11179]: info: :
hp-check[11179]: info: :Missing Required Dependencies
hp-check[11179]: info: :-----------------------------
error: 'libtool' package is missing/incompatible
hp-check[11179]: info: :
hp-check[11179]: info: :Missing Optional Dependencies
hp-check[11179]: info: :-----------------------------
hp-check[11179]: info: :None

hp-check[11179]: info: :
hp-check[11179]: info: :Total Errors: 1
hp-check[11179]: info: :Total Warnings: 1
hp-check[11179]: info: :
hp-check[11179]: info: :
hp-check[11179]: info: :Done.

sudo apt-get install libtool
=============================================================
libtool is already the newest version (2.4.6-0.1).

English description
=============================================================
I ran through the update of the hplib and kept receiving the incompatibility error:
error: 'libtool' package is missing/incompatible ...
...when in fact it is already the newest version!

How do I overcome this issue?

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-23
Last reply:
2020-11-19

This question was reopened

shivani mandora (shivani1708) said : #1

hi ,

It seems that you are using very old hplip version.
Can you please install 3.20.9 from hplip portal and check once again?

Daniel Boone (dansail) said : #2

I tried the command 'sudo apt install hplip' and received the following:

Reading package lists... Done
Building dependency tree
Reading state information... Done
hplip is already the newest version (3.16.3+repack0-1).

So, where is this repository that has 3.20.9?

Can you help with this problem?

Provide an answer of your own, or ask Daniel Boone for more information if necessary.

To post a message you must log in.