installation

Asked by YogiNMnV on 2020-10-17

Today I tried to install hplip Version: 3.20.9 from https://developers.hp.com/hp-linux-imaging-and-printing/gethplip but it fails during installation concretely during make. Something about error code 2, but nothing more(I don't have logs)

distribution Linux 16.04 LTS, kernel 5.3.5-050305-generic
I had to run manually make to print out the error: it was failing because it couldn't find or link libavahi*.so

Installing following packages solved my issue.
libavahi-core-dev
libavahi-core7

Is there missing check for this package or I just have something wrong in my build?

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-10-17
Last reply:
2020-11-01
brian_p (claremont102) said : #1

> distribution Linux 16.04 LTS...

Eyebrows will probably be raised at your using this old version
of Ubuntu. Stick with it by all means, but do not expect a rush
to support your issue.

BTW, it is usual to mention the printer model you are using.

Cheers,

Brian.

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.