hplip 3.20.9 compile fails on Ubuntu 18.04 server with "/usr/bin/ld: cannot find -lImageProcessor"

Asked by James Weingarten on 2020-10-11

Trying to install hplip 3.20.9 on a Raspberry Pi 3B running Ubuntu Server 18.04.
After choosing the configuration options from the hplip-3.20.9.run script, the make command fails with "error: 'make' command failed with status code 2"
Tried running the installer with "python3 ./installer -g" and capturing the debug output.
The make process is failing with the following output:

libtool: link: g++ -DAPDK_LITTLE_ENDIAN -g -O2 -DCONFDIR=\"/etc/hp\" -o hpcups hpcups-HPCupsFilter.o hpcups-dbuscomm.o hpcups-Compressor.o hpcups-Mode2.o hpcups-Mode3.o hpcups-Mode9.o hpcups-Mode10.o hpcups-ModeDeltaPlus.o hpcups-ModeJbig.o hpcups-ErnieFilter.o hpcups-EncapsulatorFactory.o hpcups-Encapsulator.o hpcups-Pcl3.o hpcups-Pcl3Gui.o hpcups-Pcl3Gui2.o hpcups-LJMono.o hpcups-LJColor.o hpcups-LJFastRaster.o hpcups-LJJetReady.o hpcups-LJZjStream.o hpcups-LJZxStream.o hpcups-Job.o hpcups-Pipeline.o hpcups-Processor.o hpcups-RasterSender.o hpcups-ColorMatcher.o hpcups-Halftoner.o hpcups-Scaler.o hpcups-dj400ColorMaps.o hpcups-dj600ColorMaps.o hpcups-dj970ColorMaps.o hpcups-dj8xxColorMaps.o hpcups-dj4100ColorMaps.o hpcups-BreakTables.o hpcups-Utils.o hpcups-SystemServices.o hpcups-QuickConnect.o hpcups-ModeJpeg.o jccolor.o jdatadbf.o hpcups-Lidil.o hpcups-LidilCompress.o hpcups-dj3320ColorMaps.o hpcups-dj3600ColorMaps.o hpcups-Hbpl1.o utils.o hpcups-Hbpl1_Wrapper.o hpcups-genPCLm.o hpcups-genJPEGStrips.o hpcups-RunLenEncoding.o -L./prnt/hpcups/ -ljpeg -ldl -lImageProcessor -lcups -lcupsimage -lz
/usr/bin/ld: skipping incompatible ./prnt/hpcups//libImageProcessor.so when searching for -lImageProcessor
/usr/bin/ld: cannot find -lImageProcessor
collect2: error: ld returned 1 exit status
Makefile:5511: recipe for target 'hpcups' failed
make: *** [hpcups] Error 1

error: 'make' command failed with status code 2

I've tried this script on DietPi, Debian 10.6, and Ubuntu 18.04 Server without success.
Any suggestions would be welcome.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-10-15
Last query:
2020-10-15
Last reply:
2020-10-12

This question was reopened

Best Manfred Hampl (m-hampl) said : #1

As far as i know ImageProcessor is a proprietary piece of software from HP whose source is not publicly available, and the precompiled libImageProcessor.so library is available only for i386 and amd64 architecture.

see Bug #1785230

Thanks Manfred Hampl, that solved my question.

So much for making a Raspberry Pi into a scanner server...