while installing in linux mint 20 ,it gave error message not supporting linux mint 20. Will it work properly or not ?

Asked by Swati Biswas on 2020-08-03

I recently moved from windows 7 to Linux mint 20 and get to knew that HPLIP works in Linux OS. While I was installing it showed error message saying Do not support Linux mint 20, latest support if for Linux mint 19.
Since I am new to this OS, I am concern Will the application work properly in interacting with my printer? in Linux mint20?

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Swati Biswas
Solved:
2020-08-05
Last query:
2020-08-05
Last reply:
2020-08-05
brian_p (claremont102) said : #1

What is your printer model?

--
Brian.

Swati Biswas (swati99) said : #2

HP DeskJet Ink Advantage 5075

brian_p (claremont102) said : #3

Is the 5075 connected by wireless or USB?

Swati Biswas (swati99) said : #4

it is connected throught USB to the PC.

brian_p (claremont102) said : #5

Thanks. Please give what you get for these two commands:

  systemctl list-units "ipp-usb*" | grep service

  driverless

brian_p (claremont102) said : #6

Sorry! The first command should be:

  systemctl list-units "ippusbxd*" | grep service

Swati Biswas (swati99) said : #8

swati@Swati-PC:~$ systemctl list-units "ippusbxd*" | grep service
swati@Swati-PC:~$ driverless
swati@Swati-PC:~$

This is what showed when I run these two commands

brian_p (claremont102) said : #9

Not what I expected. ippusbxd is on a Mint 20 system and the command I gave
should show it running when the printer is plugged in. It isn't running. Give the
output of

  lsusb -v | grep -A 3 "bInterfaceClass.*7

If it becomes necessary, is it possible for you to get the 5075 on the network
with wireless?

Swati Biswas (swati99) said : #10

Sorry my printer was not connected when I run those command lines ......
Wait I am trying with Prinetr power on.

These are the results:
swati@Swati-PC:~$ systemctl list-units "ippusbxd*" | grep service
  ippusbxd@001:005.service loaded active running Daemon to make IPP-over-USB printers available as network printers (001:005)
swati@Swati-PC:~$ driverless
ipp://DeskJet%205000%20series%20%5BTH79E491RM%5D._ipp._tcp.local/
swati@Swati-PC:~$

brian_p (claremont102) said : #12

Much better :).

The output of 'driverless' is a URI for the printer. **Substitute** for it in

  lpadmin -p 5075 -v URI -E -m everywhere

Can you print with

  lp -d 5075 /etc/nsswitch.conf ?

Swati Biswas (swati99) said : #13

on running this command : lp -d 5075 /etc/nsswitch.conf
at first printer started to print then it suddenly showed error message.

Print Error
There was a problem sending document 'nsswitch.conf'(job 1) to the printer.

brian_p (claremont102) said : #14

This could be due to ippusbxd not behaving itself. Try switching off the printer,
disconnecting it, Then after a few minutes switch on and reconnect. Try the
printing command a few times.

If this does not work out, I'll give you a method for print queue setup with HPLIP.

Swati Biswas (swati99) said : #15

I tried again and it printed. So will the software work properly in Linux mint 20 ?

Swati Biswas (swati99) said : #16

and will it better to do Manual Installation?

brian_p (claremont102) said : #17

> and will it better to do Manual Installation?

The technique I provided fits in with what Mint 20 provides by default and
it apparently works as advertised. You are not using HPLIP. As far as I am
concerned, you should mark this issue as solved. I am not inclined to take
it any further.

Cheers,

Brian.

Swati Biswas (swati99) said : #19

Thanks for quick response and support Brian :)

brian_p (claremont102) said : #20

> Thanks for quick response and support Brian :)

Your engagement with the issue helped a lot. Thanks.

I would offer this piece of advice: if ippusbxd continues to work for you,
then that is good., stay as you are.However, read the IPP-over-USB sections
at

  https://wiki.debian.org/CUPSDriverlessPrinting

ipp-usb is more competent than ippusbxd and is likely to replace it
eventually. You can download it from

    https://download.opensuse.org/repositories/home:/pzz/xUbuntu_20.04/amd64/

Remove ippusbxd before installing.

Happy printing,

Brian.