HP PhotoSmart 2710 ?

Asked by Francois Ochsenbein on 2020-07-24

Hello,
Looking at the list of HP printers working on Linux, found at
https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index
I ordered the model "HP PhotoSmart 2710 All-in-one Printer" included in this list, indicated with "Full" support level, and working with HPLIP 0.9.5. When I got it, and tried to install it on my Raspberry with the "hp-setup" program. But my new printer is not recognized, despite of having HPLIP-3.16.11 installed -- a much much higher version ! I tried to install the last HPLIP version from the sourceforge repository, but it fails for a raspberry with a problem of libraries (prnt/hpcups/libImageProcessor.so which is a link to libImageProcessor-x86_32.so, which can't work on an ARM architecture). So what is possible to do ?
Thank you in advance for any help !
François

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-07-27
Last reply:
11 hours ago
Francois Ochsenbein (f0x1) said : #1

In fact it's worse, hp printers require now to download a HP-smart application for the setup (no screen on the printer) and of course such an application does not exist for linux − hplip does not help unfortunately. Looks like HP wants to tranform its users into hostages…

brian_p (claremont102) said : #2

The only thing I know about the OS on a Raspberry is that it could be some
form of Debian. If it is, you have

  https://wiki.debian.org/CUPSPrintQueues

to guide you.

--
Brian.

Francois Ochsenbein (f0x1) said : #3

Well, it is definitvely Debian, but on an armhf architecture (NOT x86), and the 'make' ends with incompatible prnt/hpcups/libImageProcessor.so file, as mentioned in my original message. This share object file is a link to libImageProcessor-x86_32.so, and no sources are available to create this .so file.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.