Unable to communicate with devide (cpd=12) and (code=5012) DeskJet 4100

Asked by Patrick Palczewski on 2020-07-22

I have a DeskJet 4100 series directly connected via USB. When HPLIP installs it, it finds and sets the printer automatically, but then throws both of the errors (code=12) and (code=5012). This is a brand-new printer.

So I have reinstalled CUPS and HPLIP (version 3.20.6).

When I try to print a test page, the system both CUPS and HPLIP notify me that a job was started. Yet, the printer moves the printer heads bak and forth, but does not feed the paper. Then after a minute or so, it notifies me again that the job completed successfully.

The printer is set up via the CUPS server at localhost. This is the device URI that I get when I look at the printer properties: hp:/usb/DeskJet_Plus_4100_series?serial=CN04E2V4C9

Also, I noted that when I attempted to setup the printer for wireless printing, it finds the printer, but clicking in Step 2. But, clicking Next does nothing, no errors, it just hangs. So, I have read and tried all the solutions I've seen to no avail.

It prints test pages from the buttons on the machine, that's the only printing it does.

My system:
Dell Inspiron 3670
Ubuntu 20.04 with Kernel 5.4.0-42-generic.

If you need more info, let me know. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Patrick Palczewski
Solved:
2020-07-24
Last query:
2020-07-24
Last reply:
2020-07-24

This question was reopened

Also, in trying to solve this issue, in hp-toolbox, if I select Manual Discovery and put in the USB device address, when I click Nexst, nothing comes up. Here is the listing of my USB devices:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 413c:301a Dell Computer Corp. Dell MS116 USB Optical Mouse
Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 1a2c:0e24 China Resource Semico Co., Ltd USB Keyboard
Bus 001 Device 004: ID 03f0:1953 HP, Inc DeskJet Plus 4100 series
Bus 001 Device 003: ID 0c45:636b Microdia USB 2.0 Camera
Bus 001 Device 009: ID 0cf3:e005 Qualcomm Atheros Communications
Bus 001 Device 002: ID fafa:fafa
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So, I put in the appropriate address (03f0:1953), and it can't find the printer, saying No device found.

shivani mandora (shivani1708) said : #2

Hi ,

Ubuntu 20.04 is supported with few limitations in HPLIP. Hence you are seeing device busy error.

Could you please refer below link for your bug:

https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1879206

You can print via network instead of USB.

Thank you. you pointed me in the right direction.

I was able to get the WiFi set up using the HP Smart app. Then I opened HPLIP and chose Network/Ethernet/Wireless, opened the Advanced Options and selected mDNS as my choice. It found the printer and set it up and it successfully printed a test page.

So, the printer works, finally! I hope this soltion works for toerhs as well.

Take care!