Unable to connect by WIFI to HP printer Ubuntu 20.04

Asked by John White on 2020-07-18

Hi,
I have a new laptop with Intel i5 10210U 8GB RAM 500GB SSD running Ubuntu 20.04 from new.
I have an HP Color Laserjet MFP M277dw
I have installed hplip, version 3.20.3

dpkg -l hplip gives...

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-==============-============-============================================
ii hplip 3.20.3+dfsg0-2 amd64 HP Linux Printing and Imaging System (HPLIP)

When I connect directly to the printer by USB cable I get two instances of the printer:
HP_Color_LaserJet_MFP_M277dw
HP_Color_LaserJet_MFP_M277dw_fax

The USB printer works just fine; I haven't tested the fax as I have on phone line to it.

The USB connection is a pain and I want to work across wifi. The laptop connects to the internet across wifi with no problem.

I can also connect to my router by Ethernet, but neither by Wifi nor with Ethernet, can I connect to the printer, even though I have created a network share for the printer on my Mac. The Ubuntu laptop does not find either a WiFi printer, or the same printer connected to the LAN (which it is), or the Mac share on the LAN. The only other printer it detects is a generic CUPS connection.

Previously I had a very basic laptop running Elementary OS, which always connected to the printer without difficulty.

I would appreciate helpful suggestions as to the approach to take, but as I am much more familiar with Mac OS, I would appreciate it if the instructions don't assume prior command line knowledge !

Many Thanks,
John

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
shivani mandora
Solved:
2020-07-25
Last query:
2020-07-25
Last reply:
2020-07-25
Best shivani mandora (shivani1708) said : #1

Hi ,

Here is few things you can do to setup your printer via wifi or network:

1. Please make sure printer and system both are in same network.
2. If you know the IP of the printer , you can do $hp-setup IP_of_the _printer and setup the device.

John White (johnw360) said : #2

Thanks shivani mandora, that solved my question.