hplip for Leap 15.2

Asked by Alexander Hucke on 2020-07-13

Hello,

I try to install hp-setup 3.20.6 on a Suse Leap 15.2, but I am failing.
Could it be the case that this distro isn't yet supported by the driver?

If this is the case when will be a compatible driver for Leap 15.2?

Regards
Alex

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-07-13
Last reply:
2020-07-19
brian_p (claremont102) said : #1

Knowing the printer make and model would be useful.

Cheers,

Brian.

Alexander Hucke (alexe64) said : #2

Hello Brian,

I've a LasetJer Professional 1102w.

Within the release notes of hplip, you can see for which distro they've added the support.
So I'm curious if there a hplip version for SuSE 15.2, because it isn't mentioned.

kind regards
Alex

brian_p (claremont102) said : #3

Hello Alexander,

Use 'lpinfo -m | grep 1102w' to see whether a PPD is on the machine already that
could be installed with lpadmin or the cups web interface.

Personally, I would use

  https://wiki.debian.org/CUPSDriverlessPrinting

Cheers,

Brian.

Alexander Hucke (alexe64) said : #4

Hello Brian,

many thanks for your help.
Here is the response of your command:

localhost:/home/alex # lpinfo -m | grep 1102w
HP/hp-laserjet_professional_p_1102w.ppd.gz HP LaserJet Professional p 1102w, hpcups 3.20.6
drv:///hp/hpcups.drv/hp-laserjet_professional_p_1102w.ppd HP LaserJet Professional p 1102w, hpcups 3.20.6
manufacturer-PPDs/hplip/hp-laserjet_professional_p_1102w.ppd.gz HP LaserJet Professional p 1102w, hpcups 3.20.6

shivani mandora (shivani1708) said : #5

Hi ,

Leap 15.2 is yet not supported by HPLIP.
It will be supported in our next release.

Alexander Hucke (alexe64) said : #6

Hey Shivana,

that is really good news.

Is there a timeframe when the new driver will be released?

best regards
Alex

brian_p (claremont102) said : #7

Hello Alexander,

The PPD to use is

  drv:///hp/hpcups.drv/hp-laserjet_professional_p_1102w.ppd

Now get a URI using

  lpinfo -v

Substitute for both in

  lpadmin -p 1102w -v URI -E -m PPD

Test printing with

  lp -d 1102w /etc/nsswitch.conf

You need to install a plugin too.

Can you help with this problem?

Provide an answer of your own, or ask Alexander Hucke for more information if necessary.

To post a message you must log in.