Print fails Lubuntu 20.04

Asked by Stephen on 2020-06-08

I cannot get HP Deskjet 3720 printing to work since I upgraded to Linux Lubuntu 20.04 (from 19.04 where printing was fine).

via
HPLIP-gui (installed from Muon package mgr)
and/or HPLIP-toolbox (installed from hplip-3.20.5.run which seemed to complete ok even though it failed to install some dependencies (but only after I had installed some of these manually).

Printing still works ok in LUB19.04 +in Windows10 (dual-boot)

All on same desktop pc.

Is there a known bug with Linux (L)Ubuntu 20.04, stopping HP deskjet3720 printing? (via HPLIP)?

Any workaround? - other than my own dual-boot as above. OR fix planned soon?

Thx from 3rdRockGuy Stephen (UK)

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
brian_p
Solved:
2020-06-14
Last query:
2020-06-14
Last reply:
2020-06-12
brian_p (claremont102) said : #1

> I cannot get HP Deskjet 3720 printing to work since I upgraded to
> Linux Lubuntu 20.04 (from 19.04 where printing was fine).

I imagine we could debug this by knowing where you came from and
what you have ended up with. However, it is a lot easier (for me) to ask
you to put the 3720 on the network with a wireless connection and give
the output of 'driverless'.

Cheers,

Brian.

Stephen (3rdrockstephen) said : #2

Snds like a good idea, Brian, ***except I have not got wireless on my Lubuntu 20.04 pc (I think) - or at least only ever used wired on it. ***How can I check if wireless is pos? - on this pc, in Lubuntu 20.04.

Windows 10 on same PC (dual-boot) shows:
1) Services: WLAN auto-config +WI-FI Direct Services = both enabled and running.
2) Device Mgr - Network Adapters =
"Intel... Network connection"
"Microsoft... kernel... adapter"
+ 8x "WAN..."
***3) But Network adapters =shows only wired

3rdRockGuy Stephen

brian_p (claremont102) said : #3

The 3720 has a wireless facility. I assume your router has too. Connect printer
and router wirelessly. The computer can communicate with the router and hence
with the printer.

Cheers,

Brian.

Stephen (3rdrockstephen) said : #4

ooo! I didn't know you could do that. Will try (as soon as I find out how to do it).
Watch this space...
3rdRockGuy.

PS How do I send you an attachment?

Stephen (3rdrockstephen) said : #5

https://drive.google.com/file/d/1HW5OhEyDREf7WvMT3Aq8wdW3DjG0pAtt/view?usp=sharing
https://drive.google.com/file/d/1f-sHhcGheb1oniz2ljcUpkGKym2bf8jX/view?usp=sharing
=printer Troubleht Report (+My copy/paste of some output)
after printing failed again in Lubuntu 20.04.

3rdRockGuy

Best brian_p (claremont102) said : #6

Try 'apt purge ippusbxd'.

shivani mandora (shivani1708) said : #7

Hi ,

Please refer below link for your issue related to ubuntu 20 on HPLIP:

https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1879206

Stephen (3rdrockstephen) said : #8

Yay! We have printing liftoff! +Again and again.

=inc. after reboots +over several days.

BIG thx to "Ask Brian" - as I shall call your service, Brian - for your suggestion:
**** apt purge ippusbxd *****

From 3rdRockStephen (:-) bunny again.

Stephen (3rdrockstephen) said : #9

Thanks brian_p, that solved my question.

Thanks Brian, work also for me, USB & wifi
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1879206

hooray thanks. worked for me too..
thanks Brian..i hereby dub thee BRAIN!
hehe