can't install HPLIP on Linux Mint 19.1 cinnamon

Asked by OldPete Gounaris on 2020-06-03

OS : Linux Mint cinnamon
ver : 19.1
OLD (dead) printer : HP-Officejet-Pro-8610
NEW Printer : HP 7155 Envy Photo

1st problem : hplip-3.20.5.run stops w/ invalid characters

2d problem : Can't access install instructions - The requested page "/hp-linux-imaging-and-printing/es/hp-linux-imaging-and-printing/install/install/index" could not be found.

Results of 'hp-check -t' :

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

warning: 22-19.1 version is not supported. Using 22-18.2 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.15.0-64-generic #73-Ubuntu SMP Thu Sep 12 13:16:13 UTC 2019 GNU/Linux
 Host: mary-ZN241IC
 Proc: 4.15.0-64-generic #73-Ubuntu SMP Thu Sep 12 13:16:13 UTC 2019 GNU/Linux
 Distribution: 22 19.1
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 22 distro 19.1 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 06/03/20 14:09:06
version = 3.17.10

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -
 error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 error: dbus DBus - Message bus system REQUIRED - 1.12.2 MISSING 'DBUS may not be installed or not running'
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
 network network -wget OPTIONAL - 1.19.4 OK -
 avahi-utils avahi-utils OPTIONAL - 0.7 OK -

------------------------
| General Dependencies |
------------------------

 error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
 error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
 error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
 error: libpthread libpthread - POSIX threads library REQUIRED - b'2.27' MISSING 'libpthread needs to be installed'
 error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
 sane SANE - Scanning library REQUIRED - - OK -
 error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
 error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 MISSING 'libcrypto needs to be installed'
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.8 OK -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.6 OK -
 python3-xml Python XML libraries REQUIRED - 2.2.5 OK -
 error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.8 MISSING 'python3-devel needs to be installed'
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -

--------------
| COMPILEDEP |
--------------

 error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
 error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.4.0 MISSING 'gcc needs to be installed'
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.17.10 OK -
 hpmudext IO-Extension REQUIRED - 3.17.10 OK -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.10 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.17.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP-Officejet-Pro-8610
---------------------
Type: Printer
Device URI: hp:/usb/HP_Officejet_Pro_8610?serial=CN4APDX3SP
PPD: /etc/cups/ppd/HP-Officejet-Pro-8610.ppd
warning: Failed to read /etc/cups/ppd/HP-Officejet-Pro-8610.ppd ppd file
PPD Description:
Printer status: printer HP-Officejet-Pro-8610 is idle. enabled since Thu 27 Feb 2020 10:04:29 AM EST
error: Unable to communicate with device (code=12): hp:/usb/HP_Officejet_Pro_8610?serial=CN4APDX3SP
error: Device not found
error: Communication status: Failed

--------------
| PERMISSION |
--------------

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libjpeg8-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'build-essential' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'openssl' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
error: 'build-essential' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'mate-notification-daemon' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 18
Total Warnings: 0

Done.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-06-07
Last query:
2020-06-07
Last reply:
2020-06-06
shivani mandora (shivani1708) said : #1

Hi,

From your output , it seems that you have been using old version of HPLIP.

Please use latest HPLIP 3.20.5 from the HPLIP portal. That should solve your problem.

OldPete Gounaris (oldpete) said : #2

Hello,

OldPete Gounaris (oldpete) said : #3

Thank you for the reply, but as I titled the question, I can’t install the latest version. I have downloaded HPLIP-3.20.5 four times from 2 mirror sites, but the install stops and says invalid characters. I have tried repeatedly to open the installation instructions but every time I try the link I get a “requested page can’t be found.” error.
Does anyone have the instructions? If so, can you post them?

Manfred Hampl (m-hampl) said : #4

Please provide the full output that you receive when trying to install the latest HPLIP version with the command

sh hplip-3.20.5.run

brian_p (claremont102) said : #5

Hello OldPete,

If you are dead set on debugging hplip I'm afraid I have nothing to offer
in pursuit of that task. However, if getting printing going on Mint 19.x is
your major concern, I think we can sort something out quite quickly.

However, it does involve changing the USB connections to network ones.
After doing that, the outputs of

  avahi-browse -rt _ipp._tcp

and

  avahi-browse -rt _uscan._tcp

would be needed.

Cheers,

Brian.

OldPete Gounaris (oldpete) said : #6

Thank you Manfred!
I’ll try that Saturday afternoon, and post the results.

Brian,
I should have mentioned that I’m in Michigan and my 84 year old mother is in Florida. I remote in to try to help, but she has no spare cables and not much patience with troubleshooting over the phone. I appreciate your taking the time to post! I have no desire to debug HPLIP, but for some reason, ever time I downloaded it. Linux opened a window and loaded it into a text editor. Thank you again!

Best Manfred Hampl (m-hampl) said : #7

The last sentence is what I expected. You are not supposed to open that file with a text editor (e.g. by double-clicking on it), but you have to open a terminal window (e.g. by simultaneously pressing ctrl-alt-t) and then issue the command

sh hplip-3.20.5.run

If this tells that it cannot file the file, then you have to change directory first, probably

cd Downloads
sh hplip-3.20.5.run

OldPete Gounaris (oldpete) said : #8

Hello Manfred!

Thank you! I ran it as you mentioned and it completed successfully?
when I ran the hp-check -t command, it still showed 17, not 20. I changed the repository settings and tried again. This time the installer asked to remove 17 as it could interfere with 20 installing. removed it and I think it worked. It's waiting for plugging the USB back in! Tomorrow - Mom's asleep.

You're amazing! Thank you!

OldPete Gounaris (oldpete) said : #9

Thanks Manfred Hampl, that solved my question.