scan does not work

Asked by stéphane levant on 2020-05-26

Hi,

I install a new version of ubuntu (20.04) and my scanner (printer HP Envy 5540) does not work anymore.
It worked with my old version of ubuntu so I dont understand why.
I tried to purge and reinstall hplip without success.

> hp-scan

HP Linux Imaging and Printing System (ver. 3.20.3)
Scan Utility ver. 2.2

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

-----------------
| SELECT DEVICE |
-----------------

  Num Scan device URI
  -------- -------------------------------------------------
  0 escl:http://::1:60000
  1 hpaio:/usb/ENVY_5540_series?serial=TH64K2N14B0671

Enter number 0...1 for device (q=quit) ?1
warning: No destinations specified. Adding 'file' destination by default.
Using device hpaio:/usb/ENVY_5540_series?serial=TH64K2N14B0671
Opening connection to device...
error: SANE: Error during device I/O (code=9)

> scanimage -d 'hpaio:/usb/ENVY_5540_series?serial=TH64K2N14B0671'
Output format is not set, using pnm as a default.
scanimage: open of device hpaio:/usb/ENVY_5540_series?serial=TH64K2N14B0671 failed: Error during device I/O

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
stéphane levant
Solved:
2020-05-27
Last query:
2020-05-27
Last reply:
2020-05-27
brian_p (claremont102) said : #1

What happens when you choose 0 instead of 1?

Brian.

stéphane levant (arsunik) said : #2

With the previous version of ubuntu, I used the hpaio
It does not work with 0 :

Enter number 0...1 for device (q=quit, <enter>=default: 1*) ?0
warning: No destinations specified. Adding 'file' destination by default.
Using device escl:http://127.0.0.1:60000
Opening connection to device...
Capability : [(null)]
Capability : [image/jpeg]
Capability : [image/jpeg]
error: Failed to get the source from device.

brian_p (claremont102) said : #3

Is the scanner discovered with 'sane-find-scanner'? What is the
output from 'scanimage -L'?

stéphane levant (arsunik) said : #4

> scanimage -L
device `escl:http://127.0.0.1:60000' is a ESCL ENVY 5540 series [TH64K2N14B0671] flatbed scanner
device `hpaio:/usb/ENVY_5540_series?serial=TH64K2N14B0671' is a Hewlett-Packard ENVY_5540_series all-in-one

> sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [HP], product=0xce11 [ENVY 5540 series]) at libusb:002:003
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

brian_p (claremont102) said : #5

Both outputs look ok. I can understand why hpaio doesn't work,
but

 scanimage -d escl:http://127.0.0.1:60000 > image.pnm

should be successful with SANE on 20.04.

What happens after doing 'apt purge ippusbxd'? The daemon is
easily reinstalled if wanted.

stéphane levant (arsunik) said : #6

scanimage failed with or without ippusbxd but with a different message : scanner seems to work and the hp printer said it is ok but :

> scanimage -d 'escl:http://127.0.0.1:60000'
Output format is not set, using pnm as a default.
Capability : [(null)]
Capability : [image/jpeg]
Capability : [image/jpeg]
scanimage: rounded value of br-x from 0 to 0
scanimage: rounded value of br-y from 0 to 0
scanimage: sane_start: Invalid argument

I try another tools and xsane works with 'escl:http://127.0.0.1:60000' !
I prefer scanimage and command line tools but I will use xsane since command line does not work.
Thanks for help.

brian_p (claremont102) said : #7

I said:

> I can understand why hpaio doesn't work,...

ippusbxd is started automatically when a device is plugged in. It
takes over the USB interface and therefore libsane-hpaio cannot
use it, but the sane-escl backend can. Why xsane but not scanimage
should work is unexpected.

Glad you are now scanning.

Brian.