Need HP-OfficeJet-Pro-9020.ppd

Asked by Frederick Beihold on 2020-05-23

Hi,

A new HP OfficeJet Pro 9025 arrived.

I went through all 14 steps:
https://developers.hp.com/hp-linux-imaging-and-printing/install/install/index

But, the HP OfficeJet Pro 9025 did not work. I'm using Ubuntu 18.04 LTS.

Opened terminal and typed ~$ hp-check -t
There were no errors, and 1 warning.
The returned feedback said "HP-OfficeJet-Pro-9020.ppd" not installed. Also, 2 other similarly named ppd-files were not installed. How can I get these files and install them using only Ubuntu 18.04 LTS?

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-05-23
Last reply:
2020-05-24
brian_p (claremont102) said : #1

> Need HP-OfficeJet-Pro-9020.ppd

No - you do not need such a PPD for printing. See

  https://wiki.debian.org/CUPSDriverlessPrinting

I would connect the device by wireless and use lpadmin to set up a queue.

Cheers,

Brian.

brian_p (claremont102) said : #2

Your issue has been answered. You have not marked it as solved.
Is there a reason for that?

Brian.

Can you help with this problem?

Provide an answer of your own, or ask Frederick Beihold for more information if necessary.

To post a message you must log in.