HP MFP M128FN will not scan . Plug in download teminates

Asked by richard mabie

hplip will not scan to computer. Version 3.14.4 worked. version 3.18.3 does not, attempted to download 3.20.11 . Indicated I need to download plug in. Ran test page. Test page indicated that version 3.18.3 was active. When trying to scan, window popped up indicating the need to install plugin. I tried this 2 ways using hp-setup (v3.20.11) and encryption key could not be verified. I tried skipping the key and installation aborted. I tried using hp-plugin and pretty much the same results.

Scan has worked in the past using 3.14.4 but I cannot locate that plugin.

System setup
AMD FX8320 3.5 Ghz 16 Gb Dual Boot
Mint 18.3 1tb HD
Mint 19.3 512 Gb SSD
The printer will not scan on either version of Mint. Up until ~ 3 weeks ago it worked on Mint 18.3 (actually the main reason for 18.3 on the machine)

Please advise
My email is: <email address hidden>
Thanks in advance

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
brian_p (claremont102) said :

Plugins may be downloaded from


Install with, for example:

  sh hplip-3.14.4-plugin.run


Revision history for this message
Delano D. Vanover (esq) said :

Went to the link given, click on hplip-3.20.11 plugin. Plugin self extracted. Typed the "sh command" to install. Terminal rejected the command "cannot open the self extracted file." How is the self extracted file used? I'm at a complete lost as to what to do.
 your help would be appreciated.


Can you help with this problem?

Provide an answer of your own, or ask richard mabie for more information if necessary.

To post a message you must log in.