HP Device Manager Setup: plugin install succeeds but setup thinks it failed

Asked by Alan Backlund on 2020-04-14

I recently upgraded to Linux Mint 19.3 and am installing HP Device Manager for my HP Color LaserJet MFP m277dw.

When I run HP Device Manager Setup it runs the Driver Plug-in Installation. The plugin install reports "Plug-in installation successful" but when I dismiss that dialog an HP Device Manager Setup dialog pops up saying:

The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins.
Please run 'hp-plugin' as normal user to install plug-ins.
Visit http://hplipopensource.com for more infomation.

Aside: when I first tried to run HP Device Manager Setup I had wrong version of python set as default initially (3 not 2). I fixed that (changed default back to python2) but now I am stuck.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Anam Alam
Solved:
2020-04-18
Last query:
2020-04-18
Last reply:
2020-04-17
Best Anam Alam (anam03) said : #1

Kindly download the latest HPLIP build from https://developers.hp.com/hp-linux-imaging-and-printing

Download the plugin from

 https://developers.hp.com/hp-linux-imaging-and-printing/plugins

and install with

 sh YOUR_DOWNLOADED_PLUGIN_FILE

e.g. If your hplip is 3.20.3 , download the plugin file - hplip-3.20.3-plugin.run

Alan Backlund (alan-backlund) said : #2

I was using the latest builds but I found a work around . I was using the gui mode and it appears the gui components were failing to communicate there results. I tried the interactive (console) mode and it installed correctly.