scanning from laserjet 100 color MFP m175a

Asked by adil elsir haimoura on 2020-04-05

hello

I am using manjaro with hplip 3.20.3
I can print fine but I can not scan at all
it seems like the scanner is not supported any more .. I had an other system installed with linux mint and hplip 3.18.10 it can see the scanner but it produce I/o error communicating with scanner
any advise!!
here are the command and out put
lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 009: ID 03f0:062a HP, Inc HP LaserJet 100 colorMFP M175a
Bus 001 Device 004: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 003: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 012: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 011: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 001 Device 010: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and here is: scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

and here is sane-find-scanner

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x062a [HP LaserJet 100 colorMFP M175a]) at libusb:001:009
found USB scanner (vendor=0x148f [Ralink], product=0x5370 [802.11 n WLAN]) at libusb:001:003

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
adil elsir haimoura
Solved:
2020-04-07
Last query:
2020-04-07
Last reply:
2020-04-06
shivani mandora (shivani1708) said : #1

Hi,

can you please install Plugin and try . You can download plugin from

https://developers.hp.com/hp-linux-imaging-and-printing/plugins

This is a workaround which I found in some forums of Arch linux
1. Copy model.dat from hplip 3.18.xx to 3.20.xx and it will work for hp-setup to find the printer and the scanner..
However, it still willproduce I/O error when trying to scan.

2. Re installe the hplip-plugin after the above mentioned copy of the model.dat from the hplip 3.18 and the xsane will see the scanner and scans well
So I think it is a depreciation problem for the old MFP's from Hplip because this solution I found for different model but the result is the same!!
I am marking this as solved but I think it should be fixed!!