How do I modify configure for cups on debian 10?

Asked by Derrell Durrett on 2020-03-21

I ran "

./configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --disable-libusb01_build --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build"

 on Debian 10.

Currently, I get "

checking for cupsDoFileRequest in -lcups... no
configure: error: cannot find libcups support
"
But "

$ locate libcups
/usr/lib/x86_64-linux-gnu/libcups.so.2
/usr/lib/x86_64-linux-gnu/libcupsfilters.so.1
/usr/lib/x86_64-linux-gnu/libcupsfilters.so.1.0.0
/usr/lib/x86_64-linux-gnu/libcupsimage.so.2
/usr/lib/x86_64-linux-gnu/qt5/plugins/printsupport/libcupsprintersupport.so
"

So, my impression is that ./configure could use a flag to tell it where to find libcups. I can't (easily, anyway) find where that is.

How do I get configure to properly locate libcups?

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-21
Last reply:
2020-03-23

Also, I added --libdir=/usr/lib/x86_64-linux-gnu, but this didn't change the result.

shivani mandora (shivani1708) said : #2

Hi,

Could you please check with the latest version of HPLIP 3.20.3?
If it still shows the same error,then some package is still missing in your system. Which needs to be installed in your system manually

Can you help with this problem?

Provide an answer of your own, or ask Derrell Durrett for more information if necessary.

To post a message you must log in.