hplip 3.20 install issue

Asked by michele moretti on 2020-03-18

I'm trying to install hplip 3.20 for my HPm28w printer on Puppy Linux kernel 4.19.23 (bionicpup64_8.0).
From terminal running hplip.3.20.3.run I got the message to run it as user and on a root (I don't how) and error message about impossibility to install automatically the dependency.
I uncompressed pdd file of my printer from the directory created by hplip 3.20.... file.
Installed the printer from Cup 2.2.7. I tried to print test page.
I got the message: stopped "Filter failed".
What can I do to solve my problem?

Regards
Michele

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-18
Last reply:
2020-04-03
brian_p (claremont102) said : #1

Do you have an HP LaserJet Pro MFP M28a or an HP LaserJet Pro MFP M28w?

What versions of CUPS and cups-filters are on your system?

--
Brian.

michele moretti (michelone) said : #2

M28w

CUPS 2.2.7 (hplip 3.17.10+repack0-5)
CUPS filter 1.20.2

Michele

Il mer 18 mar 2020, 16:37 brian_p <email address hidden> ha
scritto:

> Your question #689366 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/689366
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Do you have an HP LaserJet Pro MFP M28a or an HP LaserJet Pro MFP M28w?
>
> What versions of CUPS and cups-filters are on your system?
>
> --
> Brian.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/689366
>
> You received this question notification because you asked the question.
>

brian_p (claremont102) said : #3

Put the M28w on the network and give the outputs of

  avahi-browse -rt _ipp._tcp

and

 avahi-browse -rt _uscan._tcp

--
Brian.

michele moretti (michelone) said : #4

Avahi <command not found>
The printer Is on the network and work fine I tried puppy 32 bit and After
I update hplip (19......) The printer worked well.
It doesn't in puppy 64 because I find the day to update hplip installed on
OS.

Michele

Il mer 18 mar 2020, 19:47 brian_p <email address hidden> ha
scritto:

> Your question #689366 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/689366
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Put the M28w on the network and give the outputs of
>
> avahi-browse -rt _ipp._tcp
>
> and
>
> avahi-browse -rt _uscan._tcp
>
> --
> Brian.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/689366
>
> You received this question notification because you asked the question.
>

brian_p (claremont102) said : #5

> Avahi <command not found>

avahi-browse is in the avahi-utils package. However, you appear to have
printing working now. You could mark this topic as "solved",

michele moretti (michelone) said : #6

Not I havent solved anything. The printer doesn't work on puppy 64 bit.

Michele

Il mer 18 mar 2020, 21:52 brian_p <email address hidden> ha
scritto:

> Your question #689366 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/689366
>
> brian_p posted a new comment:
> > Avahi <command not found>
>
> avahi-browse is in the avahi-utils package. However, you appear to have
> printing working now. You could mark this topic as "solved",
>
> --
> You received this question notification because you asked the question.
>

brian_p (claremont102) said : #7

Without the outputs to the commands I gave earlier I cannot proceed.

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.