HPLIP 3.19.6 failing to recognize LJ 2600n binary plugin

Asked by Burt Bicksler on 2020-02-27

Trying to get my old HP LJ Color 2600n printer working with HPLIP 3.19.6 on Ubuntu 19.10.
It tries to install the required plug in from HP, but says it can't get the key from the server.

So telling it to go ahead it first says that the plugin installed successfully, but then another pop up says that I need to manually install as a regular user.

So try that with the same basic results. Can't get the key, and says install was successful.

But HPLIP refuses to see that the plugin has been installed.

How do I resolve this issue?

Thanks,

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Burt Bicksler
Solved:
2020-02-28
Last query:
2020-02-28
Last reply:
2020-02-27
brian_p (claremont102) said : #1
Burt Bicksler (burt-e) said : #2
Burt Bicksler (burt-e) said : #3
Burt Bicksler (burt-e) said : #4

I've got things limping back to some form of normal. Here's what I had to do to resolve issues with 3.20.2 on Ubuntu/Pop OS 19.10:

For the Deskjet 6800 I would up just installing it via the normal printer admin app in 19.10. This works perfectly but when I try to add this printer using HPLIP it refuses to print, just sits at "processing" with the led on the printer blinking green.

Had a similar bit of fun with the HP LJ m402dn, when installed from HPLIP I either get garbage printed, or duplex printing doesn't work. Reverted to an installation that I had on another machine from the Ubuntu/PopOS 19.10 printer admin app and again this now prints correctly including duplex but not using HPLIP. I spent some time trying to modify the printer config created by HPLIP to match my older config, I was able to get a test page to print but couldn't get duplex to work. So sticking with the non-hplip config for now.

The HP Color LJ 2600n was a lot more fun..
Here's how I got it to finally work:
1 - Downloaded the plugin.run and .asc files from https://developers.hp.com/hp-linux-imaging-and-printing/plugins
2 - sudo apt-get install apparmor-utils
3 - sudo aa-disable /usr/share/hplip/plugin.py
4 - Tried running hp-setup but had issues..
5 - run hplip-plugin as normal user (not sudo)
6 - Plugin finally will be installed.
7 - Use the Ubuntu/PopOS printer admin app to add the LJ 2600n color printer
8 - Use the CUPS web interface to change the PPD from the default foomatic 2600n one to the first HP Color LJ 2600n one that uses the binary plugin.
9 - From the CUPS web interface print a test page, expect this to take a fairly long time to complete. It took a couple of minutes on my fairly beefy desktop. If this doesn't work check the connection type for the LJ 2600n printer in the CUPS web interface and see if that makes a difference.

Note that I used the above steps because hp-setup continued to insist that it needed to install the binary plugin even though the plugin was definitely installed in the earlier steps above.

So for now I'm saying it is solved since I can finally print again, but not sure what will happen with the next HPLIP update.