Printer won't recognise ink cartridges

Asked by Robert Dring on 2020-02-08

I have used equivalent cartridges from First Call Inks successfully for several weeks, but now my printer will not recognise them, and both cartridge lights flash. What do I need to do to solve this problem and rectify the "missing/incompatible" items shown by hp-check?

Printer is HP deskjet 2540 all-in-one.

Operating system is Linux Mint 19.3 Cinnamon 32-bit.

hp-check output:

Saving output in log file: /home/robert/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

warning: 22-19.3 version is not supported. Using 22-18.2 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:25 UTC 2019 GNU/Linux
 Host: robert-MP061
 Proc: 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:25 UTC 2019 GNU/Linux
 Distribution: 22 19.3
 Bitness: 32 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 22 distro 19.3 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[fax]
email_address =
voice_phone =

[installation]
date_time = 02/08/20 15:43:15
version = 3.17.10

[last_used]
device_uri = "hp:/usb/Deskjet_2540_series?serial=CN48E4F2DQ0604"
printer_name = HP-Deskjet-2540-series
working_dir = .

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = true
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1581092336
notify_upgrade = false
pending_upgrade_time = 0

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -
 error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 error: dbus DBus - Message bus system REQUIRED - 1.12.2 MISSING 'DBUS may not be installed or not running'
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
 network network -wget OPTIONAL - 1.19.4 OK -
 avahi-utils avahi-utils OPTIONAL - 0.7 OK -

------------------------
| General Dependencies |
------------------------

 error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
 error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
 error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
 libpthread libpthread - POSIX threads library REQUIRED - b'2.27' OK -
 error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
 sane SANE - Scanning library REQUIRED - - OK -
 error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
 error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 MISSING 'libcrypto needs to be installed'
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.9 OK -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.6 OK -
 python3-xml Python XML libraries REQUIRED - 2.2.5 OK -
 error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.9 MISSING 'python3-devel needs to be installed'
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -

--------------
| COMPILEDEP |
--------------

 error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
 error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.4.0 MISSING 'gcc needs to be installed'
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.17.10 OK -
 hpmudext IO-Extension REQUIRED - 3.17.10 OK -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.10 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.17.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/Deskjet_2540_series?serial=CN48E4F2DQ0604' is a Hewlett-Packard Deskjet_2540_series all-in-one
device `hpaio:/net/deskjet_2540_series?ip=192.168.1.66&queue=false' is a Hewlett-Packard deskjet_2540_series all-in-one

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI Model
  -------------------------------- ----------------------
  hp:/usb/Deskjet_2540_series?seri HP Deskjet 2540 series
  al=CN48E4F2DQ0604

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP-Deskjet-2540-series
----------------------
Type: Printer
Device URI: hp:/usb/Deskjet_2540_series?serial=CN48E4F2DQ0604
PPD: /etc/cups/ppd/HP-Deskjet-2540-series.ppd
warning: Failed to read /etc/cups/ppd/HP-Deskjet-2540-series.ppd ppd file
PPD Description:
Printer status: printer HP-Deskjet-2540-series disabled since Sat 08 Feb 2020 12:34:53 Greason unknown
Communication status: Good

--------------
| PERMISSION |
--------------

USB HP-Deskjet-2540-series Required - - OK Node:'/dev/bus/usb/001/006' Perm:' root lp rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libjpeg8-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'openssl' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
error: 'build-essential' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'mate-notification-daemon' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 16
Total Warnings: 0

Done.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-02-08
Last reply:
2020-02-10

This question was originally filed as bug #1862462.

Robert Dring (robertdring) said : #1

I just need to know how to solve this problem so I can go on using non-HP cartridges which are so much more affordable than the ones HP want me to use!

shivani mandora (shivani1708) said : #2

Hi,

You need to contact HP support hardware team for your cartridge issue.

Can you help with this problem?

Provide an answer of your own, or ask Robert Dring for more information if necessary.

To post a message you must log in.