HPLIP Not Detecting CUPS, Xsane or libusb

Asked by Jithendra Fernando on 2020-02-02

I cannot seem to get my HP Ink Tank working no matter what I try. I'm a little new to Linux, but I've tried everything I could find on forums. When I go to Settings -> Devices -> Printers Zorin shows that Printer is ther. lsusb Detects Hewlett- Packard:

Bus 002 Device 006: ID 03f0:1053 Hewlett-Packard

But I can't get it to print or Scan. Please help, or share a link to a previous question if I have missed it!
Thanks!

sudo hp-check gives the following:

Kernel: 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17 06:14:09 UTC 2020 GNU/Linux
Proc: 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17 06:14:09 UTC 2020 GNU/Linux
 Distribution: 0 15
 Bitness: 64 bit

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
warning: Could not access file: No such file or directory
 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -
 error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 error: dbus DBus - Message bus system REQUIRED - 1.12.2 MISSING 'DBUS may not be installed or not running'
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
 network network -wget OPTIONAL - 1.19.4 OK -
 avahi-utils avahi-utils OPTIONAL - 0.7 OK -

------------------------
| General Dependencies |
------------------------

 error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
 error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
 error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
 error: libpthread libpthread - POSIX threads library REQUIRED - b'2.28' MISSING 'libpthread needs to be installed'
 error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
 sane SANE - Scanning library REQUIRED - - OK -
 error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
 error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 MISSING 'libcrypto needs to be installed'
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.9 OK -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 4.12.1 MISSING 'python3-pyqt4-dbus needs to be installed'
 python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.12.1 OK -
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.6 OK -
 python3-xml Python XML libraries REQUIRED - 2.2.5 OK -
 error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.9 MISSING 'python3-devel needs to be installed'
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -

--------------
| COMPILEDEP |
--------------

 error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
 error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - - MISSING 'gcc needs to be installed'
 error: make make - GNU make utility to maintain groups of programs REQUIRED 3.0 - MISSING 'make needs to be installed'

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.17.10 OK -
 hpmudext IO-Extension REQUIRED - 3.17.10 OK -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.10 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.17.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

Ink-Tank-310-series
-------------------
Type: Unknown
Device URI: usb://HP/Ink%20Tank%20310%20series?serial=CN93P5G3TW06PH&interface=1
PPD: /etc/cups/ppd/Ink-Tank-310-series.ppd
PPD Description: HP DeskJet 310 Foomatic/pcl3 (recommended)
Printer status: printer Ink-Tank-310-series is idle. enabled since Sun 29 Dec 2019 14:57:08 +0530
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

--------------
| PERMISSION |
--------------

error: Unsupported model: Ink_Tank_310_series

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None

Total Errors: 17
Total Warnings: 2

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-02-04
Last reply:
2020-02-04
brian_p (claremont102) said : #1

> HPLIP-Version: HPLIP 3.17.10

Your device did not become supported until HPLIP 3.18.7. You could
download the latest version from HP and install it.

I would be interested in what you get when you execute

  lsusb -v | grep -A 10 bInterfaceClass.*7

--
Brian.

Jithendra Fernando (jf94) said : #2

Hi Brian,

I've been trying to install the latest version, but it looks like there's a lot of dependencies that HPLIP cannot locate.

lsusb -v | grep -A 10 bInterfaceClass.*7 gives the following:

Couldn't open device, some information will be missing
      bInterfaceClass 7 Printer
      bInterfaceSubClass 1 Printer
      bInterfaceProtocol 2 Bidirectional
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x08 EP 8 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing
Couldn't open device, some information will be missing

It looks like this could take a while, getting all the dependencies individually. I can't think of anything else at the moment.

brian_p (claremont102) said : #3

Hello Jithendra,

You say:

> I've been trying to install the latest version, but it looks like there's a
> lot of dependencies that HPLIP cannot locate.

Hopefully this installation attempt hasn't messed up your system (Ubuntu
18.04?). What I would do is

 * Download hplip_3.19.12+dfsg0-3.debian.tar.xz from
    https://packages.ubuntu.com/focal/hplip.
 * Extract hp-ink_tank_310_series.ppd from the package
    and put it in /usr/share/ppd.
 * Extract models.dat from the package and put it in
    /usr/share/hplip/data/models/. (Backup the copy that
    is already there).

You should now be able to set up a print queue with the CUPS webinterface
or whatever you prefer to use. (Best is to use hp:/... as the URI).

Can you help with this problem?

Provide an answer of your own, or ask Jithendra Fernando for more information if necessary.

To post a message you must log in.