HPLIP link to Linpus not valid

Asked by Geoff


On this web page:


...the link in Step 2 to ....


returns the following error:

Page not found
The requested page could not be found.

Can anybody please tell me where I can obtain the Linpus rpm, thanks.
I am trying to get a HP Officejet J4680 working on an Aspire Acer One(Linpus).
Have wasted many hours trying to use HPLIP 3.9.2 , but not able to print.
I am hoping hplipfull-3.9.4.linpus will provide the answer.


Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Aaron Albright
Last query:
Last reply:
Revision history for this message
Best Aaron Albright (albrigha-deactivatedaccount) said :

Fixed. Sorry about that.


Revision history for this message
Geoff (gm-www) said :

Thanks Aaron Albright, that solved my question.

Revision history for this message
Geoff (gm-www) said :

By using hplipfull-3.9.4.linpus my HP Officejet J4680 is now printing OK from my Acer Aspire One (AOA150) via the wireless connection.

This is how I got things to work OK:

1 - Removed existing install of HPLIP 3.9.4
Initially I had installed HPLIP 3.9.2, which did not work (scanning worked OK, but not printing)
To remove this install I followed the instructions at:

2 - Then installed hplipfull-3.9.4.linpus by following the instructions in this link

But at the last line in Step 3 the instruction: su -c "rpm -Uvh hplipfull-3.9.2.linpus-linux-2.6-intel.rpm" returned an error message. I changed the 3.9.2 part to 3.9.4, but still the same.
I therefore ran hplipfull-3.9.4.linpus.rpm (saved on Desktop) from File Manager.

After running hp-setup, a test page was printed automatically. Tested the scanner which also worked OK. Do not need the FAX, so have not configured or tested that part.