hplip error: A required dependency cups-devel and cups-image

Asked by tiago correa alves barreto on 2019-11-21

Installing hplip-3.19.11 on ubuntu 18.04.3 LTS (bionic) returns dependency error:

error: A required dependency 'cups-devel (Common Unix Printing System development files)' is still missing.
error: A required dependency 'cups-image (CUPS image - CUPS image development files)' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

And I can't find these dependencies. Help me please

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-21
Last reply:
2019-12-07
brian_p (claremont102) said : #1

Your printer is?

--
Brian.

HP laserjet professional p 1102w

brian_p (claremont102) said : #3

I have no idea why you think you need HPLIP 3.19.11. This device is
supported by HPLIP on Ubuntu 18.04.3 LTS (bionic). Please give the
output of 'lpinfo -v'.

--
Brian.

I will explain the scenario:

I work in a company with domain.

  - Printer is shared on shared Windows computer

Installation Way:

I went into settings> printers> add printers> via samba> clicked browse> selected the printer on the network> proceeded with the installation. In the end gave 'hplip.pluguin' error

When I had hplip installed the cups-devel and cups-image dependency was missing.

Now follow the output of the requested command. (HP laserjet professional p 1102w printer is not listed)

file cups-brf:/
network https
network beh
network ipp
network socket
network http
network lpd
network ipps
network smb
file cups-x2go:/
network bjnp
network dnssd://HP%20Color%20LaserJet%20MFP%20M277dw%20(ABA710)._ipp._tcp.local/?uuid=564e4238-4836-544c-5851-308d99aba710
network dnssd://HP%20Designjet%20T120%20%5B48A093%5D._ipp._tcp.local/?uuid=abcd8d00-272d-f6ef-1ce3-a1b8421bd755
network dnssd://HP%20LaserJet%20400%20M401dne%20(77A7C7)._ipp._tcp.local/?uuid=42524453-4739-5050-4b4b-a01d4877a7c7
network dnssd://HP%20LaserJet%20400%20M401n%20(77CDA3)._ipp._tcp.local/?uuid=42524453-4833-5753-4d48-a01d4877cda3
network dnssd://HP%20LaserJet%20MFP%20M426dw%20(23FA33)._ipp._tcp.local/?uuid=50484238-4a36-5644-434b-ec8eb523fa33
network dnssd://HP%20LaserJet%20MFP%20M426dw%20(FCD14D)._ipp._tcp.local/?uuid=42524253-4b44-4837-4858-480fcffcd14d
network dnssd://Kyocera%20ECOSYS%20M3040idn._ipp._tcp.local/?uuid=4509a320-0079-0056-00e4-00250750362c
network dnssd://RDV4A8912%20(BCB1814A8912)._printer._tcp.local/
network dnssd://RDVEE8D8C%20(BCB181EE8D8C)._printer._tcp.local/
network socket://146.164.63.195
network socket://146.164.63.197
network socket://146.164.63.214:9100
network lpd://146.164.63.243/lp
network socket://146.164.63.244
network lpd://146.164.63.247/lp
network ipp://NPIABA710.local:631/ipp/print
network ipp://HP02BAD0DFBE7D.local:631/ipp/print
network ipp://NPI77A7C7.local:631/ipp/print
network ipp://NPI77CDA3.local:631/ipp/print
network ipp://NPI23FA33.local:631/ipp/print
network ipp://NPIFCD14D.local:631/ipp/print
network ipp://KM5431BF.local:631/ipp/print

brian_p (claremont102) said : #5

CUPS cannot see your 1102w, so it cannot communicate with it. You
will need to look at your setup,

--
Brian.

It once worked ...

I believe that only the installation of hplip.plugin is missing. But the cups-devel and cups-image dependencies are missing.

brian_p (claremont102) said : #7

Whether a plugin is installed or not does not affect CUPS and its ability to
discover a device.

You haven't really explained why you need HPLIP 3.19.11 .

--
Brian.

I don't know if I need exactly this version. It is with this version that I am trying to install the printer.

When I install via samba Windows share, he finds the printer, finds the drivers, and completes the installation. When I put it to print, it displays an error asking to install 'hplip.plugin'.

I go to the HP website, download the latest hplip and run the install script. At the time of installing the dependencies, failed.

Hi Brian!

Can you understand me?

Can you help me find this dependency?

brian_p (claremont102) said : #10

You were asked for the output of 'lpinfo -v'. You gave it and as you said

 > ...(HP laserjet professional p 1102w printer is not listed)

You have lots of URIs for other printers but not for the p1102w. Without it,
 it is not possible to set up a print queue.

I understand you but am not going to deal with a printer with a missing URI.
I consider the missing dependency not to be important.

--
Brian.

I assure you that in the previous version it worked!

I remember doing the same printer installation process. Then I installed hplip, then I installed hplip-plugin and it worked.

Problem is hplip installation that has missing dependencies.

Launchpad Janitor (janitor) said : #12

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.