Page centering - HP Deskjet 3700

Asked by Sandro Magrini on 2019-11-20

The print cuts the upper margin and the output results not centered in the page but move to the high.
This is the output of the command "hp-check -t":

hp-check[5151]: info: :
hp-check[5151]: info: :HP Linux Imaging and Printing System (ver. 3.19.6)
hp-check[5151]: info: :Dependency/Version Check Utility ver. 15.1
hp-check[5151]: info: :
hp-check[5151]: info: :Copyright (c) 2001-18 HP Development Company, LP
hp-check[5151]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[5151]: info: :This is free software, and you are welcome to distribute it
hp-check[5151]: info: :under certain conditions. See COPYING file for more details.
hp-check[5151]: info: :
hp-check[5151]: info: :Note: hp-check can be run in three modes:
hp-check[5151]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[5151]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[5151]: info: :are installed to successfully compile HPLIP.
hp-check[5151]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro
hp-check[5151]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
hp-check[5151]: info: :has the proper dependencies installed to successfully run.
hp-check[5151]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode
hp-check[5151]: info: :will check both of the above cases (both compile- and run-time dependencies).
hp-check[5151]: info: :
hp-check[5151]: info: :Check types:
hp-check[5151]: info: :a. EXTERNALDEP - External Dependencies
hp-check[5151]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[5151]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[5151]: info: :d. [All are run-time checks]
hp-check[5151]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[5151]: info: :
hp-check[5151]: info: :Status Types:
hp-check[5151]: info: : OK
hp-check[5151]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[5151]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[5151]: info: :
warning: ubuntu-19.10 version is not supported. Using ubuntu-19.04 versions dependencies to verify and install...
hp-check[5151]: info: :
hp-check[5151]: info: :---------------
hp-check[5151]: info: :| SYSTEM INFO |
hp-check[5151]: info: :---------------
hp-check[5151]: info: :
hp-check[5151]: info: : Kernel: 5.3.0-23-generic #25-Ubuntu SMP Tue Nov 12 09:22:33 UTC 2019 GNU/Linux
 Host: SAJF-PC
 Proc: 5.3.0-23-generic #25-Ubuntu SMP Tue Nov 12 09:22:33 UTC 2019 GNU/Linux
 Distribution: ubuntu 19.10
hp-check[5151]: info: : Bitness: 64 bit

hp-check[5151]: info: :
hp-check[5151]: info: :-----------------------
hp-check[5151]: info: :| HPLIP CONFIGURATION |
hp-check[5151]: info: :-----------------------
hp-check[5151]: info: :
hp-check[5151]: info: :HPLIP-Version: HPLIP 3.19.6
hp-check[5151]: info: :HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro 19.10 version
hp-check[5151]: info: :
hp-check[5151]: info: :Current contents of '/etc/hp/hplip.conf' file:
hp-check[5151]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.19.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.19.6
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

hp-check[5151]: info: :
hp-check[5151]: info: :Current contents of '/var/lib/hp/hplip.state' file:
hp-check[5151]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[5151]: info: :
hp-check[5151]: info: :Current contents of '~/.hplip/hplip.conf' file:
hp-check[5151]: info: :[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[fax]
email_address =
voice_phone =

[last_used]
device_uri = "hp:/usb/DeskJet_3700_series?serial=CN94A6P01X06GZ"
printer_name =
working_dir = .

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1564153870
notify_upgrade = false
pending_upgrade_time = 0

[installation]
date_time = 11/20/19 16:35:17
version = 3.19.6

hp-check[5151]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[5151]: info: :
hp-check[5151]: info: :-------------------------
hp-check[5151]: info: :| External Dependencies |
hp-check[5151]: info: :-------------------------
hp-check[5151]: info: :
hp-check[5151]: info: : error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
hp-check[5151]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.27 OK -
hp-check[5151]: info: : error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
hp-check[5151]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
hp-check[5151]: info: : error: dbus DBus - Message bus system REQUIRED - 1.12.14 MISSING 'DBUS may not be installed or not running'
hp-check[5151]: info: : policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
hp-check[5151]: info: : network network -wget OPTIONAL - 1.20.3 OK -
hp-check[5151]: info: : avahi-utils avahi-utils OPTIONAL - 0.7 OK -
hp-check[5151]: info: :
hp-check[5151]: info: :------------------------
hp-check[5151]: info: :| General Dependencies |
hp-check[5151]: info: :------------------------
hp-check[5151]: info: :
hp-check[5151]: info: : error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
hp-check[5151]: info: : error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
hp-check[5151]: info: : error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
hp-check[5151]: info: : libpthread libpthread - POSIX threads library REQUIRED - b'2.30' OK -
hp-check[5151]: info: : error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
hp-check[5151]: info: : sane SANE - Scanning library REQUIRED - - OK -
hp-check[5151]: info: : error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
hp-check[5151]: info: : error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
hp-check[5151]: info: : error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 MISSING 'libcrypto needs to be installed'
hp-check[5151]: info: : python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.7.5 OK -
hp-check[5151]: info: : python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[5151]: info: : error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
hp-check[5151]: info: : error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
hp-check[5151]: info: : python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.12 OK -
hp-check[5151]: info: : python3-xml Python XML libraries REQUIRED - 2.2.7 OK -
hp-check[5151]: info: : error: python3-devel Python devel - Python development files REQUIRED 2.2 3.7.5 MISSING 'python3-devel needs to be installed'

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Sandro Magrini
Solved:
2019-11-22
Last query:
2019-11-22
Last reply:
2019-11-21
brian_p (claremont102) said : #1

Hello Sandro,

Execute 'driverless'. This gives you a URI. Substitute it in the command

  lpadmin -p 3700 -v URI -m everywhere

Does 'lp -d 3700 /etc/nsswitch.conf' print?

Sandro Magrini (magrinis) said : #2

Dear Brian, thank you for your help.
I executed the commands you suggested, obtaining that the URI is "ipp://HPC465164AC02F.local:631/ipp/print", but the command lp gives an error message (in Italian) stating that the printer 3700 is not accepting any document

brian_p (claremont102) said : #3

Apologies, Sandro.. I omitted the option -E (enable the queue).

  lpadmin -p 3700 -v URI -E -m everywhere

--
Brian.

Sandro Magrini (magrinis) said : #4

Thank you again!
Now the command works. I also printed again the an .ODT document from Libreoffice on the new printer defined by "lpadmin" and the problem seems to be solved.