Debian Buster (10) error installing it

Asked by atux on 2019-11-13

I did a fresh install of Debian 10 x64 in my laptop and i have downloaded the hplip version 3.19.11. When executing the script it mention's that i am running version 10.1 but the script is for version 10 only. Then it continues and i am getting the following errors:
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: debian-10.1 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.0 version packages.

Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*):

Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
Please wait, this may take several minutes...
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK

RE-CHECKING DEPENDENCIES
------------------------
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.
atux@laptop:~/Downloads$

Is there any way to fix the issue and have my printer working in Debian Buster (10), please?

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-13
Last reply:
2019-11-18
brian_p (claremont102) said : #1

> I did a fresh install of Debian 10 x64 in my laptop and i have
> downloaded the hplip version 3.19.11.

Why? What is lacking on your OS?

--
Brian.

Sergio Ciordia (sciordia) said : #2

Hi Brian, this is the same problem that I have with Raspbian Buster 10.

https://answers.launchpad.net/hplip/+question/685829

I avoid the atux's problemdoing a custom installation and disabling Qt4 dependencies and enabling Qt5 but in the end I have an error in the "Running make" step.

Sergio

shivani mandora (shivani1708) said : #3

Hi,

Debian 10.1 is yet not supported by HPLIP. Hence you are seeing this behavior. We will release Debian 10.1 by our next release.

Sergio Ciordia (sciordia) said : #4

Great News Shivani, thank you very much.

Sergio

Can you help with this problem?

Provide an answer of your own, or ask atux for more information if necessary.

To post a message you must log in.