hp-setup does not detect wireless HP Officejet 7740 printer

Asked by Tom Bivens on 2019-10-22

I am running Linux Mint 19.2 on Ubuntu 18.04.
The printer is an HP Officejet Pro 7740 wireless.
The printer is connected to the network and shows up in my printers list.
I can print to the printer.
I installed HPLIP, but there is no scanning functionality.
I want to get the scanning working for this printer.
Thanks.

--------------
10/24/2019
This issue is resolved.
I was unable to install the plugin, hplip-3.19.8-plugin.run because I already had hplip 3.17.10 installed on my system.
I tried to install hplip-3.19.8.run, but when the installer stopped working while trying to uninstall the previous version. I let it run for over 2 hours, but would never 'finish' uninstalling.
I finally found the command "sudo apt-get purge hplip hplip-data hplip-doc hplip-gui hpijs-ppds \
libsane-hpaio printer-driver-hpcups printer-driver-hpijs".
This command worked.
Now when I installed hplip-3.19.8.run, the installation did not detect a previous version and installed correctly. After installation, I was prompted to install the plugin, which also installed flawlessly.
Thank you for your attention to my issue. I would suggest looking into the process of uninstalling previous versions as well as posting manual steps to remove previous versions.
Tom

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
shivani mandora
Solved:
2019-10-25
Last query:
2019-10-25
Last reply:
2019-10-25
shivani mandora (shivani1708) said : #1

Hi,

Can you please download plugin file from below link:

https://developers.hp.com/hp-linux-imaging-and-printing/plugins

And install it using below command:

$sh hplip-3.19.8.plugin.run

After that try to scan from your printer.

Tom Bivens (tmbiv56) said : #2

Thank you.
Here is the result:
-----------------
$ sh hplip-3.19.8-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.8 Plugin Self Extracting Archive..............................................................
Error: plugin version mismatch
---------------------
My version of hplip is 3.17.10 with Device Manager Version: 15. (Qt4).

Should I upgrade to hplip 3.19.8 or just install the plugin for 3.17?

Sorry that I failed to list my version number in the first post.

Best shivani mandora (shivani1708) said : #3

Hi,

If your issue is resolved can you please close the issue from your side?

Tom Bivens (tmbiv56) said : #4

Thanks shivani mandora, that solved my question.