hplip not found hplj100color-mfp-m175 from network

Asked by Andrew on 2019-10-22

After upgrading from Ubuntu x64 from April 18 to April 19, HPLIP refused to scan and print through the HP_LaserJet_100_colorMFP_M175nw_181898_connected via LAN through a multifunction printer.
Assuming that the update was unsuccessful, I tried to install Ubunt 19.04 x64 again, but hplip refused to work in this case either. I tried Mint 19.2 x64 and Debian 10.1 the result was the same. HPLIP did not find the printer, although in one of the Linux installations mint itself found a network printer and was able to print normally through it, but the scanner still did not work. HPLIP did not find anything on the network.
I even downgraded. set ubuntu 18.04 but hplip didn’t work in it either. I even installed the previous version of hplip but it just did not install. In general, I despaired of getting MFPs to work under Linux. Moreover, the same printer normally works in scanner and printer mode in windows7.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-10-22
Last reply:
2019-10-25
shivani mandora (shivani1708) said : #1

Hi,

Can you please post the output of hp-check -t here?

Andrew (andrewinc) said : #2

the hp-check utility was not available, although HPLIP-3.19.8 was installed.
I had to run sudo apt install hplip
Ubuntu 19.04 (GNU/Linux 5.0.0-32-generic x86_64)
run from putty:
--------------------------------------------------------------
andrew@aecmp:~$ hp-check -t
Saving output in log file: /home/andrew/hp-check.log

HP Linux Imaging and Printing System (ver. 3.19.8)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version
                                                                                                                                                                                                                            warning: ubuntu-19.04 version is not supported. Using ubuntu-18.10 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------
                                                                                                                                                                                                                                           Kernel: 5.0.0-32-generic #34-Ubuntu SMP Wed Oct 2 02:06:48 UTC 2019 GNU/Linux
 Host: aecmp
 Proc: 5.0.0-32-generic #34-Ubuntu SMP Wed Oct 2 02:06:48 UTC 2019 GNU/Linux
 Distribution: ubuntu 19.04
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.19.8
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro 19.04 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.19.8

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-3.19.8
html=/usr/share/doc/hplip-3.19.8
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.19.8
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1569351919
pending_upgrade_time = 0
latest_available_version = 3.17.10

[installation]
date_time = 10/25/19 13:53:27
version = 3.19.8

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------
                                                                                                                                                                                                                                            cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.10 OK 'CUPS Scheduler is running' gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -

(xsane:10308): Gtk-WARNING **: 13:53:28.869: cannot open display:
 error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - INCOMPAT 'xsane needs to be installed' scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK - dbus DBus - Message bus system REQUIRED - 1.12.12 OK - policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK - network network -wget OPTIONAL - 1.20.1 OK - avahi-utils avahi-utils OPTIONAL - 0.7 OK -

------------------------
| General Dependencies |
------------------------

 libjpeg libjpeg - JPEG library REQUIRED - - OK - cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.10 OK - cups-image CUPS image - CUPS image development files REQUIRED - 2.2.10 OK -
 libpthread libpthread - POSIX threads library REQUIRED - b'2.29' OK - libusb libusb - USB library REQUIRED - 1.0 OK -
 sane SANE - Scanning library REQUIRED - - OK - sane-devel SANE - Scanning library development files REQUIRED - - OK - libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK - libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 OK - python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.7.3 OK -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.8 OK -
 python3-xml Python XML libraries REQUIRED - 2.2.6 OK - error: python3-devel Python devel - Python development files REQUIRED 2.2 3.7.3 MISSING 'python3-devel needs to be installed'
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.5.18 OK -

--------------
| COMPILEDEP |
--------------
                                                                                                                                                                                                                                            libtool libtool - Library building support services REQUIRED - 2.4.6 OK - gcc gcc - GNU Project C and C++ Compiler REQUIRED - 8.3.0 OK - make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.2.1 OK -

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.19.8 OK -
 hpmudext IO-Extension REQUIRED - 3.19.8 OK -

----------------------
| Scan Configuration |
----------------------

 hpaio HPLIP-SANE-Backend REQUIRED - 3.19.8 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.19.8 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------
                                                                                                                                                                                                                                            No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------
                                                                                                                                                                                                                                            No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

--------------
| PERMISSION |
--------------

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'xsane' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 5
Total Warnings: 0

Done.

Andrew (andrewinc) said : #3

Installed all the packages from the SUMMARY section, however, the tail hp-check -t turned out to be like this:
===========================================================
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'xsane' package is missing/incompatible

Total Errors: 1
Total Warnings: 0
==============================================================
checked Missing Optional Dependencies again - installed (output in Russian):

andrew@aecmp:~/Загрузки$ sudo apt-get install gtk2-engines-pixbuf
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет gtk2-engines-pixbuf самой новой версии (2.24.32-3ubuntu1).
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 11 пакетов не обновлено.
andrew@aecmp:~/Загрузки$ sudo apt-get install xsane
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет xsane самой новой версии (0.999-6ubuntu1).
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 11 пакетов не обновлено.

Can you help with this problem?

Provide an answer of your own, or ask Andrew for more information if necessary.

To post a message you must log in.