Ubuntu 19.04 upgrade with HPLIP 3.19.8 fails

Asked by CoolGames on 2019-10-02

I wanted to use simple scan on Ubuntu Studio 19.04 but it was not finding the scanner so I tried to re-install HPLIP 3.19.8
It had many failed to add plug in errors so gave up even though a non-delete able printer version worked in CUPS.

Scanner now is unavailable as it was working before.

error: HPLIP cannot detect devices in your network.
This may be due to existing firewall settings blocking the required ports like (5353/udp).
 When you are in a trusted network environment, you may open the ports for network services
 like mdns and slp in the firewall. For detailed steps follow the link.

I have seen one warning for an Graphtec HPGL plotter that has nothing to do with the failing HP printer

Printer status: printer Graphtec_CC100-20 is idle. enabled since Wed 03 Jan 2018 11:48:29 AM EST
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

hp-check maybe eludes to why it prints but doesn't install though I don't see the reason

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.0.0-29-lowlatency #31-Ubuntu SMP PREEMPT Thu Sep 12 14:13:01 UTC 2019 GNU/Linux
 Host: hostname
 Proc: 5.0.0-29-lowlatency #31-Ubuntu SMP PREEMPT Thu Sep 12 14:13:01 UTC 2019 GNU/Linux
 Distribution: 12 19.04
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.19.8
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for ubuntu distro 19.04 version

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1570036280
pending_upgrade_time = 0
latest_available_version = 3.17.10

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-10-02
Last reply:
2019-10-03
shivani mandora (shivani1708) said : #1

Hi,

It seems link you plugin version is 3.17.10. Please install latest plugin version using below command:

$sh hplip-3.19.8.plugin.run

And connect the printer through IP. Please let me know if you face any issue.

Can you help with this problem?

Provide an answer of your own, or ask CoolGames for more information if necessary.

To post a message you must log in.