the problems for the HPLIP 3.19.8,

Asked by John on 2019-09-10

Dear Support

We have the problems for the HPLIP 3.19.8, we have installed that on the SuSe Linux Enterprise 11 SP1, and can print the document to the HP LaserJet Pro M428FDW, but cannot scan any document, it’s shown Error IO.

Remarks: the whole install need to be off the network. And below is the hp-check.log

hp-check[21060]: info: :
hp-check[21060]: info: :[01mHP Linux Imaging and Printing System (ver. 3.19.8)[0m
hp-check[21060]: info: :[01mDependency/Version Check Utility ver. 15.1[0m
hp-check[21060]: info: :
hp-check[21060]: info: :Copyright (c) 2001-18 HP Development Company, LP
hp-check[21060]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[21060]: info: :This is free software, and you are welcome to distribute it
hp-check[21060]: info: :under certain conditions. See COPYING file for more details.
hp-check[21060]: info: :
hp-check[21060]: info: :[01mNote: hp-check can be run in three modes:[0m
hp-check[21060]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[21060]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[21060]: info: :are installed to successfully compile HPLIP.
hp-check[21060]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro
hp-check[21060]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
hp-check[21060]: info: :has the proper dependencies installed to successfully run.
hp-check[21060]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode
hp-check[21060]: info: :will check both of the above cases (both compile- and run-time dependencies).
hp-check[21060]: info: :
hp-check[21060]: info: :Check types:
hp-check[21060]: info: :a. EXTERNALDEP - External Dependencies
hp-check[21060]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[21060]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[21060]: info: :d. [All are run-time checks]
hp-check[21060]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[21060]: info: :
hp-check[21060]: info: :Status Types:
hp-check[21060]: info: : OK
hp-check[21060]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[21060]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[21060]: info: :
warning: [01m3-11 version is not supported. Using 3-15.1 versions dependencies to verify and install...[0m
hp-check[21060]: info: :
hp-check[21060]: info: :---------------
hp-check[21060]: info: :| SYSTEM INFO |
hp-check[21060]: info: :---------------
hp-check[21060]: info: :
hp-check[21060]: info: : Kernel: 2.6.32.12-0.7-pae #1 SMP 2010-05-20 11:14:20 +0200 GNU/Linux
 Host: localhost
 Proc: 2.6.32.12-0.7-pae #1 SMP 2010-05-20 11:14:20 +0200 GNU/Linux
 Distribution: 3 11
hp-check[21060]: info: : Bitness: 32 bit

hp-check[21060]: info: :
hp-check[21060]: info: :-----------------------
hp-check[21060]: info: :| HPLIP CONFIGURATION |
hp-check[21060]: info: :-----------------------
hp-check[21060]: info: :
hp-check[21060]: info: :HPLIP-Version: HPLIP 3.19.8
hp-check[21060]: info: :HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 3 distro 11 version
hp-check[21060]: info: :
hp-check[21060]: info: :[01mCurrent contents of '/etc/hp/hplip.conf' file:[0m
hp-check[21060]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.19.8

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/HP
ppdbase=/usr/share/cups/model
doc=/usr/share/doc/hplip-3.19.8
html=/usr/share/doc/hplip-3.19.8
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.19.8
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

hp-check[21060]: info: :
hp-check[21060]: info: :[01mCurrent contents of '/var/lib/hp/hplip.state' file:[0m
hp-check[21060]: info: :[plugin]
eula = 1
version = 3.19.8
installed = 1

hp-check[21060]: info: :
hp-check[21060]: info: :[01mCurrent contents of '~/.hplip/hplip.conf' file:[0m
warning: Could not access file: 沒有此一檔案或目錄
hp-check[21060]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[21060]: info: :
hp-check[21060]: info: :--------------
hp-check[21060]: info: :| COMPILEDEP |
hp-check[21060]: info: :--------------
hp-check[21060]: info: :
hp-check[21060]: info: : gcc gcc - GNU Project C and C++ Compiler REQUIRED - 4.3.4 OK -
hp-check[21060]: info: : make make - GNU make utility to maintain groups of programs REQUIRED 3.0 3.81 OK -
hp-check[21060]: info: : libtool libtool - Library building support services REQUIRED - 2.2.6 OK -
hp-check[21060]: info: :
hp-check[21060]: info: :------------------------
hp-check[21060]: info: :| General Dependencies |
hp-check[21060]: info: :------------------------
hp-check[21060]: info: :
hp-check[21060]: info: : libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 0.9.8 OK -
hp-check[21060]: info: : python-xml Python XML libraries REQUIRED - 1.95.8 OK -
hp-check[21060]: info: : libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.4.2 OK -
hp-check[21060]: info: : sane-devel SANE - Scanning library development files REQUIRED - 1.0.20 OK -
hp-check[21060]: info: : pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.6 OK -
hp-check[21060]: info: : pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.6.2 OK -
hp-check[21060]: info: : libpthread libpthread - POSIX threads library REQUIRED - 2.11.1 OK -
hp-check[21060]: info: : python-devel Python devel - Python development files REQUIRED 2.2 2.6 OK -
hp-check[21060]: info: : cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 1.3.9 OK -
hp-check[21060]: info: : python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 0.83.0 OK -
hp-check[21060]: info: :[31;01m error: cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - MISSING 'cups-ddk needs to be installed'[0m
hp-check[21060]: info: : reportlab Reportlab - PDF library for Python OPTIONAL 2.0 2.1 OK -
hp-check[21060]: info: : pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.6.2 OK -
hp-check[21060]: info: : libusb libusb - USB library REQUIRED - 1.0 OK -
hp-check[21060]: info: : cups-image CUPS image - CUPS image development files REQUIRED - 1.3.9 OK -
hp-check[21060]: info: : python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.6 OK -
hp-check[21060]: info: : python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[21060]: info: : libjpeg libjpeg - JPEG library REQUIRED - - OK -
hp-check[21060]: info: : sane SANE - Scanning library REQUIRED - 1.0.20 OK -
hp-check[21060]: info: :
hp-check[21060]: info: :----------------------
hp-check[21060]: info: :| Scan Configuration |
hp-check[21060]: info: :----------------------
hp-check[21060]: info: :
hp-check[21060]: info: : scanext Scan-SANE-Extension REQUIRED - 3.19.8 OK -
hp-check[21060]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.19.8 OK 'hpaio found in /etc/sane.d/dll.conf'
hp-check[21060]: info: :
hp-check[21060]: info: :-------------------------
hp-check[21060]: info: :| External Dependencies |
hp-check[21060]: info: :-------------------------
hp-check[21060]: info: :
hp-check[21060]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 8.62 OK -
hp-check[21060]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.20 OK -
hp-check[21060]: info: : cups CUPS - Common Unix Printing System REQUIRED 1.1 1.3.9 OK 'CUPS Scheduler is running'
hp-check[21060]: info: : network network -wget OPTIONAL - 1.11.4 OK -
hp-check[21060]: info: : policykit PolicyKit - Administrative policy framework OPTIONAL - - OK -
hp-check[21060]: info: : xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.995 OK -
hp-check[21060]: info: : dbus DBus - Message bus system REQUIRED - 1.2.10 OK -
hp-check[21060]: info: :[31;01m error: avahi-utils avahi-utils OPTIONAL - - MISSING 'avahi-utils needs to be installed'[0m
hp-check[21060]: info: :
hp-check[21060]: info: :---------------------
hp-check[21060]: info: :| Python Extentions |
hp-check[21060]: info: :---------------------
hp-check[21060]: info: :
hp-check[21060]: info: : hpmudext IO-Extension REQUIRED - 3.19.8 OK -
hp-check[21060]: info: : cupsext CUPS-Extension REQUIRED - 3.19.8 OK -
hp-check[21060]: info: :
hp-check[21060]: info: :------------------------------
hp-check[21060]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[21060]: info: :------------------------------
hp-check[21060]: info: :
hp-check[21060]: info: :device `hpaio:/usb/HP_LaserJet_Pro_M428f-M429f?serial=CN3KM2M85Q' is a Hewlett-Packard HP_LaserJet_Pro_M428f-M429f all-in-one
device `hpaio:ect hp:/usb/HP_LaserJet_Pro_M428f-M429f?serial=CN3KM2M85Q "HP LaserJet Pro M428f-M429f" "HP LaserJet Pro M428f-M429f USB CN3KM2M85Q HPLIP" "MFG:HP' is a Hewlett-Packard HP_LaserJet_Pro_M428f-M429f all-in-one
device `hpaio:/usb/HP_LaserJet_Pro_M428f-M429f?serial=CN3KM2M85Q' is a Hewlett-Packard HP_LaserJet_Pro_M428f-M429f all-in-one
device `hpaio:ect hp:/usb/HP_LaserJet_Pro_M428f-M429f?serial=CN3KM2M85Q "HP LaserJet Pro M428f-M429f" "HP LaserJet Pro M428f-M429f USB CN3KM2M85Q HPLIP" "MFG:HP' is a Hewlett-Packard HP_LaserJet_Pro_M428f-M429f all-in-one

hp-check[21060]: info: :
hp-check[21060]: info: :--------------------------
hp-check[21060]: info: :| DISCOVERED USB DEVICES |
hp-check[21060]: info: :--------------------------
hp-check[21060]: info: :
hp-check[21060]: info: : Device URI Model
hp-check[21060]: info: : ------------------------------------ ---------------------------
hp-check[21060]: info: : hp:/usb/HP_LaserJet_Pro_M428f-M429f? HP LaserJet Pro M428f-M429f
  serial=CN3KM2M85Q
hp-check[21060]: info: :
hp-check[21060]: info: :---------------------------------
hp-check[21060]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[21060]: info: :---------------------------------
hp-check[21060]: info: :
hp-check[21060]: info: :
warning: No queues found.
hp-check[21060]: info: :
hp-check[21060]: info: :--------------
hp-check[21060]: info: :| PERMISSION |
hp-check[21060]: info: :--------------
hp-check[21060]: info: :
hp-check[21060]: info: :USB HP_LaserJet_Pro_M428f-M429f Required - - OK Node:'/dev/bus/usb/001/007' Perm:' root root rw- r-- r--'
hp-check[21060]: info: :
hp-check[21060]: info: :-----------
hp-check[21060]: info: :| SUMMARY |
hp-check[21060]: info: :-----------
hp-check[21060]: info: :
hp-check[21060]: info: :[01mMissing Required Dependencies[0m
hp-check[21060]: info: :[01m-----------------------------[0m
hp-check[21060]: info: :None
hp-check[21060]: info: :
hp-check[21060]: info: :[01mMissing Optional Dependencies[0m
hp-check[21060]: info: :[01m-----------------------------[0m
error: 'cupsddk' package is missing/incompatible
error: 'avahi-utils' package is missing/incompatible
hp-check[21060]: info: :
hp-check[21060]: info: :Total Errors: 2
hp-check[21060]: info: :Total Warnings: 1
hp-check[21060]: info: :
hp-check[21060]: info: :
hp-check[21060]: info: :Done.

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-09-10
Last reply:
John (happydays1698) said : #1

Resend

Can you help with this problem?

Provide an answer of your own, or ask John for more information if necessary.

To post a message you must log in.