hplip packages missing parallel port support?

Asked by Rózsa Gábor on 2019-07-31

I have really old HP1100A multifunction printer/scanner. I have used it connected to my small home server, many years working just fine. I've decided to renew the system, upgrade to Debian 10 (buster).
I was install Debian 10 (buster) packages hplip (and libsane-hpaio) with cups and sane. Printing is working, but scanning does not work. I was trying every known utilities such as scanimage -L sane-find-scanner hp-scan and hp-probe. The result was always the invalid printer, invalid uri. (hp-probe does not offer parport selection).
Under investigation I was found in configuration file /etc/hp/hplip.conf under [configure] that option pp-build=no
I'm not sure but my old system (Debian 6.0.10) at this position was "yes", and scanner is working well.
Debian reportbug send me to this place.

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-02
Last reply:
10 hours ago
shivani mandora (shivani1708) said : #1

Hi,

Debian 10 is not supported by HPLIP yet. Hence you are seeing this behavior.
Please install supported version of Debian in HPLIP. We will be supporting Debian 10 in our future releases.

Thanks,
Shivani

Rózsa Gábor (tovis) said : #2

Thank you for quick answer!
I decided to try build from source. I planning to install on different box (then my server) where I could install every tools and dependencies for hplip.
Could you point me what option should I change to get support /dev/parport0 ?
(I was overview on site developers.hp.com "Manual Build and Install Instructions for Debian" but it seem to be really outdated Debian 6 against 10 for now)

Thanks,
tovis

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.