gobject/dbus error on Scanjet Pro 3500 f1 installation

Asked by Jean Renoir on 2019-07-29

Hello,
I've bought a HP Scanjet Pro 3500 f1 scanner, which was told to be linux compatible
I tried installing HP drivers for this device without succes on linux mint 19.1
What I did:
    - downloaded hplip-3.19.6.run: installation without problems (several dependencies where installed during the process)
    - run hp-setup: works fine until plugin installation, error:
Plug-in version: 3.19.6
Installed HPLIP version: 3.19.6
Number of files to install: 64

Plugin installation failed
error: Python gobject/dbus may be not installed
error: Plug-in install failed

According to https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/1430561, I tried to force intallation through Python2, then through Python 3. I linked /usr/bin/python towards /usr/bin/Python2 (then Python3) and started again the whole installation (reintalling hplip with each version of python)
I also tried to find and install some Python gobject/dbus component with pip3, I did'nt find anything to install

This installation error is well-known since months.
Has someone a solution?

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-05
Last reply:
2019-08-05
shivani mandora (shivani1708) said : #1

Hi,

Can you please try installing plugin through below command instead of hp-plugin:

$sh hplip-3.19.6-plugin.run

It should install plugin without any error. If you face any issue after this please let me know

Thanks,
Shivani

Jean Renoir (proof42) said : #2

Thank you for your response.

$sh hplip-3.19.6-plugin.run
=> gives:

Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.6 Plugin Self Extracting Archive..............................................................

HP Linux Imaging and Printing System (ver. 3.19.6)
Plugin Installer ver. 3.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.19.6
Installed HPLIP version: 3.19.6
Number of files to install: 64

Done

Then I did:
$hp-setup
=> Gives the following issue message:

Searching... (bus=usb, search=(None), desc=0)
Segmentation fault
error: The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins. Please run 'hp-plugin' as normal user to install plug-ins. Visit http://hplipopensource.com for more infomation.

Conclusion: plugin seems to be installed but is not. I'm under Python 3.6.8
Any other Idea?

Can you help with this problem?

Provide an answer of your own, or ask Jean Renoir for more information if necessary.

To post a message you must log in.