failed to install scan plugin, digital keys

Asked by alain soyeur on 2019-07-24

When installing hplip, and trying to install scan drivers from , I get an error with digital keys :
Receiving digital keys: /usr/bin/gpg --homedir /home/asoyeur/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9

Done.
error: Failed to install Plug-in.
Either you have chosen to skip the Plug-in installation or entered incorrect Password.
and the scanner is not functionning with sane.

* Ubutu 14.04
* hplip 3.19.6
* Printer : LaserJetPro MFP M148dw

Where can I download the driver to install it manually?

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
alain soyeur
Solved:
2019-07-25
Last query:
2019-07-25
Last reply:
2019-07-25
shivani mandora (shivani1708) said : #1

Hi,

Please try to install plugin file using below command:

sh hplip-$version-plugin.run

It should install plugin file properly. If you face any issue after this please let me know.

alain soyeur (klone31) said : #2

Sorry, but I do not have a file hplip-3.19.6-plugin.run on my computer.
I tried from command-line hp-plugin but same problem with keys from hp authorized server. I think the simpler would be to download plugin files on my computer by any mean and then from hp-plugin use "Select and install an existing local copy of the plug-in file".

alain soyeur (klone31) said : #3

Today, using hp-plugin -i I succeed to download plugin files from hp server, but after giving my sudo password, the program crashed. So I tried again and after downloading plugin I copied ~/.hplip/plugin_tmp and then launched from this directory hplip-plugin-install. The installation succeed and I can scan, but after each scan, I have a message from sane : "input-output error" but it's OK, I can use the scanner.