hp-plugin will not install for 3.19.5

Asked by Steve N on 2019-07-06

Unable to complete the install of hp-plugin for hplip 3.19.5.
1. Your Linux Distribution and version.
Linux Mint 19 Tara based on Ubuntu 18.04

2. Your printer make/model.
HP Color LaserJet MFP m277dw

3. If possible, run 'hp-check -t' and post the output.
slnutt@slnutt-ThinkPad-W530:~$ cat hp-check.log
hp-check[23417]: info: :
hp-check[23417]: info: :HP Linux Imaging and Printing System (ver. 3.19.5)
hp-check[23417]: info: :Dependency/Version Check Utility ver. 15.1
hp-check[23417]: info: :
hp-check[23417]: info: :Copyright (c) 2001-18 HP Development Company, LP
hp-check[23417]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[23417]: info: :This is free software, and you are welcome to distribute it
hp-check[23417]: info: :under certain conditions. See COPYING file for more details.
hp-check[23417]: info: :
hp-check[23417]: info: :Note: hp-check can be run in three modes:
hp-check[23417]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper
hp-check[23417]: info: :dependencies are installed to successfully compile HPLIP.
hp-check[23417]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has
hp-check[23417]: info: :the proper dependencies installed to successfully run.
hp-check[23417]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).
hp-check[23417]: info: :
hp-check[23417]: info: :Check types:
hp-check[23417]: info: :a. EXTERNALDEP - External Dependencies
hp-check[23417]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[23417]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[23417]: info: :d. [All are run-time checks]
hp-check[23417]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[23417]: info: :
hp-check[23417]: info: :Status Types:
hp-check[23417]: info: : OK
hp-check[23417]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[23417]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[23417]: info: :
hp-check[23417]: info: :
hp-check[23417]: info: :---------------
hp-check[23417]: info: :| SYSTEM INFO |
hp-check[23417]: info: :---------------
hp-check[23417]: info: :
hp-check[23417]: info: : Kernel: 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:24 UTC 2019 GNU/Linux
 Host: slnutt-ThinkPad-W530
 Proc: 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:24 UTC 2019 GNU/Linux
 Distribution: 22 19
hp-check[23417]: info: : Bitness: 64 bit

hp-check[23417]: info: :
hp-check[23417]: info: :-----------------------
hp-check[23417]: info: :| HPLIP CONFIGURATION |
hp-check[23417]: info: :-----------------------
hp-check[23417]: info: :
hp-check[23417]: info: :HPLIP-Version: HPLIP 3.19.5
hp-check[23417]: info: :HPLIP-Home: /usr/share/hplip
hp-check[23417]: info: :HPLIP-Installation: Auto installation is supported for linuxmint distro 19 version
hp-check[23417]: info: :
hp-check[23417]: info: :Current contents of '/etc/hp/hplip.conf' file:
hp-check[23417]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.19.5

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.19.5
html=/usr/share/doc/hplip-3.19.5
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.19.5
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

hp-check[23417]: info: :
hp-check[23417]: info: :Current contents of '/var/lib/hp/hplip.state' file:
hp-check[23417]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[23417]: info: :
hp-check[23417]: info: :Current contents of '~/.hplip/hplip.conf' file:
hp-check[23417]: info: :[upgrade]
notify_upgrade = true
last_upgraded_time = 1562367582
pending_upgrade_time = 0

[last_used]
device_uri = hp:/net/HP_Color_LaserJet_MFP_M277dw?ip=10.10.10.105
printer_name =
working_dir = /home/slnutt/Downloads/hplip-3.19.5.run

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 07/05/2019 16:10:58
version = 3.19.5

hp-check[23417]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[23417]: info: :
hp-check[23417]: info: :--------------
hp-check[23417]: info: :| COMPILEDEP |
hp-check[23417]: info: :--------------
hp-check[23417]: info: :
hp-check[23417]: info: : gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.4.0 OK -
hp-check[23417]: info: : make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
hp-check[23417]: info: : libtool libtool - Library building support services REQUIRED - 2.4.6 OK -
hp-check[23417]: info: :
hp-check[23417]: info: :------------------------
hp-check[23417]: info: :| General Dependencies |
hp-check[23417]: info: :------------------------
hp-check[23417]: info: :
hp-check[23417]: info: : libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 OK -
hp-check[23417]: info: : python-xml Python XML libraries REQUIRED - 2.2.5 OK -
hp-check[23417]: info: : libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
hp-check[23417]: info: : sane-devel SANE - Scanning library development files REQUIRED - - OK -
hp-check[23417]: info: : pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
hp-check[23417]: info: : pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.12.1 OK -
hp-check[23417]: info: : libpthread libpthread - POSIX threads library REQUIRED - 2.27 OK -
hp-check[23417]: info: : python-devel Python devel - Python development files REQUIRED 2.2 2.7.15 OK -
hp-check[23417]: info: : cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.7 OK -
hp-check[23417]: info: : python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.6 OK -
hp-check[23417]: info: : cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
hp-check[23417]: info: : reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -
hp-check[23417]: info: : pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.12.1 OK -
hp-check[23417]: info: : libusb libusb - USB library REQUIRED - 1.0 OK -
hp-check[23417]: info: : cups-image CUPS image - CUPS image development files REQUIRED - 2.2.7 OK -
hp-check[23417]: info: : python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.15 OK -
hp-check[23417]: info: : python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[23417]: info: : libjpeg libjpeg - JPEG library REQUIRED - - OK -
hp-check[23417]: info: : sane SANE - Scanning library REQUIRED - - OK -
hp-check[23417]: info: :
hp-check[23417]: info: :----------------------
hp-check[23417]: info: :| Scan Configuration |
hp-check[23417]: info: :----------------------
hp-check[23417]: info: :
hp-check[23417]: info: : scanext Scan-SANE-Extension REQUIRED - 3.19.5 OK -
hp-check[23417]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.19.5 OK 'hpaio found in /etc/sane.d/dll.conf'
hp-check[23417]: info: :
hp-check[23417]: info: :-------------------------
hp-check[23417]: info: :| External Dependencies |
hp-check[23417]: info: :-------------------------
hp-check[23417]: info: :
hp-check[23417]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -
hp-check[23417]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
hp-check[23417]: info: : cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.7 OK 'CUPS Scheduler is running'
hp-check[23417]: info: : network network -wget OPTIONAL - 1.19.4 OK -
hp-check[23417]: info: : policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
hp-check[23417]: info: : xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
hp-check[23417]: info: : dbus DBus - Message bus system REQUIRED - 1.12.2 OK -
hp-check[23417]: info: : avahi-utils avahi-utils OPTIONAL - 0.7 OK -
hp-check[23417]: info: :
hp-check[23417]: info: :---------------------
hp-check[23417]: info: :| Python Extentions |
hp-check[23417]: info: :---------------------
hp-check[23417]: info: :
hp-check[23417]: info: : hpmudext IO-Extension REQUIRED - 3.19.5 OK -
hp-check[23417]: info: : cupsext CUPS-Extension REQUIRED - 3.19.5 OK -
hp-check[23417]: info: :
hp-check[23417]: info: :------------------------------
hp-check[23417]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[23417]: info: :------------------------------
hp-check[23417]: info: :
hp-check[23417]: info: :device `hpaio:/net/HP_Color_LaserJet_MFP_M277dw?ip=10.10.10.105' is a Hewlett-Packard HP_Color_LaserJet_MFP_M277dw all-in-one
device `hpaio:/net/HP_LaserJet_4100_MFP?ip=10.10.10.32' is a Hewlett-Packard HP_LaserJet_4100_MFP all-in-one

hp-check[23417]: info: :
hp-check[23417]: info: :--------------------------
hp-check[23417]: info: :| DISCOVERED USB DEVICES |
hp-check[23417]: info: :--------------------------
hp-check[23417]: info: :
hp-check[23417]: info: :No devices found.
hp-check[23417]: info: :
hp-check[23417]: info: :---------------------------------
hp-check[23417]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[23417]: info: :---------------------------------
hp-check[23417]: info: :
hp-check[23417]: info: :
hp-check[23417]: info: :HP-LaserJet-100-color-MFP-M175
hp-check[23417]: info: :------------------------------
hp-check[23417]: info: :Type: Unknown
hp-check[23417]: info: :Device URI: socket://192.168.5.20:9100
hp-check[23417]: info: :PPD: /etc/cups/ppd/HP-LaserJet-100-color-MFP-M175.ppd
warning: Failed to read /etc/cups/ppd/HP-LaserJet-100-color-MFP-M175.ppd ppd file
hp-check[23417]: info: :PPD Description:
hp-check[23417]: info: :Printer status: printer HP-LaserJet-100-color-MFP-M175 is idle. enabled since Wed 19 Jun 2019 06:31:35 PM PDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
hp-check[23417]: info: :
hp-check[23417]: info: :HP_Color_LaserJet_MFP_M277dw
hp-check[23417]: info: :----------------------------
hp-check[23417]: info: :Type: Printer
hp-check[23417]: info: :Device URI: hp:/net/HP_Color_LaserJet_MFP_M277dw?ip=10.10.10.105
hp-check[23417]: info: :PPD: /etc/cups/ppd/HP_Color_LaserJet_MFP_M277dw.ppd
warning: Failed to read /etc/cups/ppd/HP_Color_LaserJet_MFP_M277dw.ppd ppd file
hp-check[23417]: info: :PPD Description:
hp-check[23417]: info: :Printer status: printer HP_Color_LaserJet_MFP_M277dw is idle. enabled since Wed 03 Jul 2019 08:00:22 PM PDT
error: Required plug-in status: Not installed
hp-check[23417]: info: :Communication status: Good
hp-check[23417]: info: :
hp-check[23417]: info: :<email address hidden>
hp-check[23417]: info: :----------------------------------------------------
hp-check[23417]: info: :Type: Unknown
hp-check[23417]: info: :Device URI: ipps://NPI174694.local:443/ipp/print
hp-check[23417]: info: :PPD: /<email address hidden>
warning: Failed to read /<email address hidden> ppd file
hp-check[23417]: info: :PPD Description:
hp-check[23417]: info: :Printer status: printer <email address hidden> is idle. enabled since Fri 05 Jul 2019 12:06:43 AM PDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
hp-check[23417]: info: :
hp-check[23417]: info: :HP_Color_LaserJet_MFP_M277dw_fax
hp-check[23417]: info: :--------------------------------
hp-check[23417]: info: :Type: Fax
hp-check[23417]: info: :Device URI: hpfax:/net/HP_Color_LaserJet_MFP_M277dw?ip=10.10.10.105
hp-check[23417]: info: :PPD: /etc/cups/ppd/HP_Color_LaserJet_MFP_M277dw_fax.ppd
warning: Failed to read /etc/cups/ppd/HP_Color_LaserJet_MFP_M277dw_fax.ppd ppd file
hp-check[23417]: info: :PPD Description:
hp-check[23417]: info: :Printer status: printer HP_Color_LaserJet_MFP_M277dw_fax is idle. enabled since Tue 08 Jan 2019 04:18:48 PM PST
error: Required plug-in status: Not installed
hp-check[23417]: info: :Communication status: Good
hp-check[23417]: info: :
hp-check[23417]: info: :HP_LaserJet_4100_MFP
hp-check[23417]: info: :--------------------
hp-check[23417]: info: :Type: Printer
hp-check[23417]: info: :Device URI: hp:/net/HP_LaserJet_4100_MFP?ip=10.10.10.32
hp-check[23417]: info: :PPD: /etc/cups/ppd/HP_LaserJet_4100_MFP.ppd
warning: Failed to read /etc/cups/ppd/HP_LaserJet_4100_MFP.ppd ppd file
hp-check[23417]: info: :PPD Description:
hp-check[23417]: info: :Printer status: printer HP_LaserJet_4100_MFP is idle. enabled since Sat 04 May 2019 05:50:38 PM PDT
error: Communication status: Failed
hp-check[23417]: info: :
hp-check[23417]: info: :
hp-check[23417]: info: :--------------
hp-check[23417]: info: :| PERMISSION |
hp-check[23417]: info: :--------------
hp-check[23417]: info: :
hp-check[23417]: info: :
hp-check[23417]: info: :-----------
hp-check[23417]: info: :| SUMMARY |
hp-check[23417]: info: :-----------
hp-check[23417]: info: :
hp-check[23417]: info: :Missing Required Dependencies
hp-check[23417]: info: :-----------------------------
hp-check[23417]: info: :None
hp-check[23417]: info: :
hp-check[23417]: info: :Missing Optional Dependencies
hp-check[23417]: info: :-----------------------------
hp-check[23417]: info: :None

hp-check[23417]: info: :
hp-check[23417]: info: :Plug-in Status
hp-check[23417]: info: :--------------
error: Plug-ins need to be installed
hp-check[23417]: info: :
hp-check[23417]: info: :Total Errors: 3
hp-check[23417]: info: :Total Warnings: 2
hp-check[23417]: info: :
hp-check[23417]: info: :
hp-check[23417]: info: :Done.

4. A detailed explanation of your problem.

I'm unable to scan using Simple Scan it says hp-plugin not installed ....
I'm unable to install hp-plugins after repeated tries and google attempts to find an workarounds, but noting is working..Here is my attempt to run 4a) sh hplip-3.19.5.run, 4b) manually hp-setup -i 10.10.10.105, and manually 4c) hp-plugin.. Please see the outputs below in turn as they are listed here.

*** 4a) sh hplip-3.19.5.run

$ sh hplip-3.19.5.run
Creating directory hplip-3.19.5
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.5 Self Extracting Archive..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................chown: changing ownership of './.libs/cupsext.soT': Operation not permitted
chown: changing ownership of './.libs/libhpipp.so.0.0.1T': Operation not permitted
chown: changing ownership of './.libs/libsane-hpaio.so.1.0.0T': Operation not permitted
chown: changing ownership of './.libs/libhpmud.so.0.0.6T': Operation not permitted
chown: changing ownership of './.libs/hpmudext.soT': Operation not permitted
chgrp: changing group of './.libs/cupsext.soT': Operation not permitted
chgrp: changing group of './.libs/libhpipp.so.0.0.1T': Operation not permitted
chgrp: changing group of './.libs/libsane-hpaio.so.1.0.0T': Operation not permitted
chgrp: changing group of './.libs/libhpmud.so.0.0.6T': Operation not permitted
chgrp: changing group of './.libs/hpmudext.soT': Operation not permitted

HP Linux Imaging and Printing System (ver. 3.19.5)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Fri-05-Jul-2019_17:07:40.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a

INTRODUCTION
------------
This installer will install HPLIP version 3.19.5 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).

DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Linux Mint 19.

Is "Linux Mint 19" your correct distro/OS and version (y=yes*, n=no, q=quit) ?

Initializing. Please wait...

ENTER USER PASSWORD
-------------------
Please enter the sudoer (slnutt)'s password:

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information. Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit:

SECURITY PACKAGES
-----------------
AppArmor is installed.
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ?

RUNNING PRE-INSTALL COMMANDS
----------------------------
OK

CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.

RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK

DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
HPLIP-3.18.12 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'q'= Quit)? :
Starting uninstallation...
HPLIP uninstallation is completed

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK

RE-CHECKING DEPENDENCIES
------------------------
OK

RUNNING SCANJET DEPENDENCY COMMANDS
-----------------------------------
sudo apt-get install --assume-yes python-pip (Scanjet-depend step 1)
sudo pip install --upgrade pip (Scanjet-depend step 2)
sudo -H pip install setuptools (Scanjet-depend step 3)
sudo pip install --upgrade setuptools (Scanjet-depend step 4)
sudo apt-get install --assume-yes libleptonica-dev (Scanjet-depend step 5)
sudo apt-get install --assume-yes tesseract-ocr (Scanjet-depend step 6)
sudo apt-get install --assume-yes libtesseract-dev (Scanjet-depend step 7)
sudo -H pip install tesserocr (Scanjet-depend step 8)
sudo apt-get install --assume-yes tesseract-ocr-eng (Scanjet-depend step 9)
sudo apt-get install --assume-yes libzbar-dev (Scanjet-depend step 10)
sudo apt-get install --assume-yes python-zbar (Scanjet-depend step 11)
sudo apt-get install --assume-yes python-opencv (Scanjet-depend step 12)
sudo apt-get install --assume-yes python-pypdf2 (Scanjet-depend step 13)
sudo -H pip install imutils (Scanjet-depend step 14)
sudo apt-get install --assume-yes imagemagick* (Scanjet-depend step 15)
sudo apt-get install --assume-yes graphicsmagick* (Scanjet-depend step 16)
sudo -H pip install pypdfocr (Scanjet-depend step 17)
sudo -H pip install scikit-image (Scanjet-depend step 18)
sudo -H pip install scipy (Scanjet-depend step 19)
OK

PRE-BUILD COMMANDS
------------------
OK

BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib/x86_64-linux-gnu --prefix=/usr --enable-qt4 --disable-qt5 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-libusb01_build --disable-foomatic-ppd-install --disable-hpijs-install --disable-class-driver --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build --enable-apparmor_build'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make clean'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make'
Please wait, this may take several minutes...
Command completed successfully.

Running 'sudo make install'
Please wait, this may take several minutes...
Command completed successfully.

Build complete.

POST-BUILD COMMANDS
-------------------

CLOSE HP_SYSTRAY
----------------
Sending close message to hp-systray (if it is currently running)...
OK

HPLIP UPDATE NOTIFICATION
-------------------------
Do you want to check for HPLIP updates?. (y=yes*, n=no) :

RESTART OR RE-PLUG IS REQUIRED
------------------------------
If you are installing a USB connected printer, and the printer was plugged in when you started this installer, you will need to either restart your PC or unplug and
re-plug in your printer (USB cable only). If you choose to restart, run this command after restarting: hp-setup (Note: If you are using a parallel connection, you will
have to restart your PC. If you are using network/wireless, you can ignore and continue).

Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit) : i

PRINTER SETUP
-------------
Please make sure your printer is connected and powered on at this time.
Do you want to setup printer in GUI mode? (u=GUI mode*, i=Interactive mode) : i
Running 'hp-setup -i' command....

HP Linux Imaging and Printing System (ver. 3.19.5)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)

--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num Connection Description
            Type
  -------- ---------- ----------------------------------------------------------
  0* usb Universal Serial Bus (USB)
  1 net Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 1

Using connection type: net

Setting up device: hp:/net/HP_Color_LaserJet_MFP_M277dw?ip=10.10.10.105

------------------------
| PLUG-IN INSTALLATION |
------------------------

Segmentation fault
error: Failed to install Plugin.
error: The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins. Please run 'hp-plugin' as normal user to install plug-ins.Visit http://hplipopensource.com for more infomation.
error: hp-setup failed. Please run hp-setup manually.

RE-STARTING HP_SYSTRAY
----------------------

HP Linux Imaging and Printing System (ver. 3.19.5)
System Tray Status Service ver. 2.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)

**** 4b) manually hp-setup -i 10.10.10.105

slnutt@slnutt-ThinkPad-W530:~$ hp-seup -i 10.10.10.105

Command 'hp-seup' not found, did you mean:

  command 'hp-setup' from deb hplip

Try: sudo apt install <deb name>

slnutt@slnutt-ThinkPad-W530:~$ hp-setup -i 10.10.10.105

HP Linux Imaging and Printing System (ver. 3.19.5)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)

Setting up device: hp:/net/HP_Color_LaserJet_MFP_M277dw?ip=10.10.10.105

------------------------
| PLUG-IN INSTALLATION |
------------------------

Segmentation fault
error: Failed to install Plugin.
error: The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins. Please run 'hp-plugin' as normal user to install plug-ins.Visit http://hplipopensource.com for more infomation.

*** 4c) hp-plugin

$ hp-plugin

HP Linux Imaging and Printing System (ver. 3.19.5)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

HP Linux Imaging and Printing System (ver. 3.19.5)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Checking for network connection...
Downloading plug-in from:
Receiving digital keys: /usr/bin/gpg --homedir /home/slnutt/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.5 Plugin Self Extracting Archive..............................................................

HP Linux Imaging and Printing System (ver. 3.19.5)
Plugin Installer ver. 3.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.19.5
Installed HPLIP version: 3.19.5
Number of files to install: 64

Plugin installation failed
error: Python gobject/dbus may be not installed
error: Plug-in install failed.

Done.

5. Steps to recreate the problem.

Please see the details above for the steps I've taken to try and work through the problem.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
shivani mandora
Solved:
2019-07-12
Last query:
2019-07-12
Last reply:
2019-07-12
Best shivani mandora (shivani1708) said : #1

Hi,

Please try to install plugin using below command:

$sh hplip-3.19.5-plugin.run

Thanks,
Shivani

Steve N (linuxsnutt) said : #2

Followed these steps and solved the hp-plugin problem can now scan,fax and print
1) Used this link to find my plugin:
http://www.linuxprinting.org/download/printdriver/auxfiles/HP/plugins/
2) Downloaded the two files to a folder on my home directory (mkdir hp-plugin) directory:
hplip-3.19.5-plugin.run
hplip-3.19.5-plugin
3) ran this command to install the hp-plugin:
sh hplip-3.19.5-plugin.run
4) ran hp-setup -u ip address of my printer HP Color LaserJet MFP m277dw
hp-setup -u 10.10.10.105
5) Ran hp-toolbox and checked status of printers
Everything is now working as expected: printer, scanner,and fax.

Steve N (linuxsnutt) said : #3

Thanks shivani mandora, that solved my question.