How to enable scanning n M?FC M129

Asked by John ffitch on 2019-06-23

Linux Opensuse 15.1

I can print and have been doing so for some time but when I try xsane id says Error during I/o and tat is all I can get. It findsthe scanner whch ids wirelessly connected

scanimage -L shows rthe device name. I tried hp-doctor but got no enlightenment

Script started on 2019-06-23 20:21:19+01:00 [TERM="xterm" TTY="/dev/pts/2" COLUMNS="80" LINES="40"]
7]2;jpff on xenakis: /home/jpff/csound6]1;xenakis8xenakis:~/csound6> hp-doctor

HP Linux Imaging and Printing System (ver. 3.18.6)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

HP Linux Imaging and Printing System (ver. 3.18.6)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Checking for Deprecated items....
error: This distro (i.e suse 15.1) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y


Checking for HPLIP updates....

HP Linux Imaging and Printing System (ver. 3.18.6)
HPLIP upgrade latest version ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.

Done.
error: Failed to upgrade latest HPLIP. Is hp-upgrade already running (i.e. foreground or background)?


Checking for Dependencies....
warning: 3-15.1 version is not supported. Using 3-42.3 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.12.14-lp151.28.4-default #1 SMP Fri May 24 07:57:46 UTC 2019 (af35fd1) GNU/Linux
 Host: xenakis
 Proc: 4.12.14-lp151.28.4-default #1 SMP Fri May 24 07:57:46 UTC 2019 (af35fd1) GNU/Linux
 Distribution: 3 15.1
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.18.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 3 distro 15.1 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.18.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
ppdbase=/usr/share/cups/model/manufacturer-PPDs
doc=/usr/share/doc/packages/hplip
html==/usr/share/doc/packages/hplip
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/lib/cups/driver
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=no
cups-ppd-install=yes
internal-tag=3.18.6
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.17.9

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[fax]
email_address =
voice_phone =

[installation]
date_time = 06/23/19 20:21:36
version = 3.18.6

[last_used]
device_uri = hpaio:/net/HP_LaserJet_MFP_M129-M134?ip=172.16.4.23
printer_name = HP_LaserJet_MFP_M129-M134
working_dir = .

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1505595688
notify_upgrade = false
pending_upgrade_time = 0

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

- \  cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.7 OK 'CUPS Scheduler is running'
| /  gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.26 OK -
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
- \  scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
| /  error: dbus DBus - Message bus system REQUIRED - 1.12.2 MISSING 'DBUS may not be installed or not running'
-  policykit PolicyKit - Administrative policy framework OPTIONAL - 0.114 OK -
\  network network -wget OPTIONAL - 1.19.5 OK -
 error: avahi-utils avahi-utils OPTIONAL - - MISSING 'avahi-utils needs to be installed'

------------------------
| General Dependencies |
------------------------

 libjpeg libjpeg - JPEG library REQUIRED - - OK -
|  error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.7 MISSING 'cups-devel needs to be installed'
/  error: cups-image CUPS image - CUPS image development files REQUIRED - 2.2.7 MISSING 'cups-image needs to be installed'
 libpthread libpthread - POSIX threads library REQUIRED - b'2.26' OK -

 libusb libusb - USB library REQUIRED - 1.0 OK -
 sane SANE - Scanning library REQUIRED - - OK -
 error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
|  error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 MISSING 'libnetsnmp-devel needs to be installed'
/  libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.0 OK -
-  python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.5 OK -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
 python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 4.12.1 OK -
 python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.12.1 OK -
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
 python3-xml Python XML libraries REQUIRED - 2.2.5 OK -
\  error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.5 MISSING 'python3-devel needs to be installed'
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 error: python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 - MISSING 'python3-reportlab needs to be installed'

--------------
| COMPILEDEP |
--------------

 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -
 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.4.0 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.2.1 OK -

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.18.6 OK -
 hpmudext IO-Extension REQUIRED - 3.18.6 OK -

----------------------
| Scan Configuration |
----------------------

 hpaio HPLIP-SANE-Backend REQUIRED - 3.18.6 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.18.6 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/HP_LaserJet_MFP_M129-M134?ip=172.16.4.23' is a Hewlett-Packard HP_LaserJet_MFP_M129-M134 all-in-one

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP_LaserJet_MFP_M129-M134
-------------------------
Type: Printer
Device URI: hp:/net/HP_LaserJet_MFP_M129-M134?ip=172.16.4.23
PPD: /etc/cups/ppd/HP_LaserJet_MFP_M129-M134.ppd
warning: Failed to read /etc/cups/ppd/HP_LaserJet_MFP_M129-M134.ppd ppd file
PPD Description:
- Printer status: printer HP_LaserJet_MFP_M129-M134 is idle. enabled since Sun 23 Jun 2019 06:20:25 PM BST
Communication status: Good

HP_LaserJet_MFP_M129-M134_fax
-----------------------------
Type: Fax
Device URI: hpfax:/net/HP_LaserJet_MFP_M129-M134?ip=172.16.4.23
PPD: /etc/cups/ppd/HP_LaserJet_MFP_M129-M134_fax.ppd
PPD Description: HP Fax2 hpcups
\ Printer status: printer HP_LaserJet_MFP_M129-M134_fax is idle. enabled since Fri 05 Jan 2018 05:33:17 PM GMT
Communication status: Good

--------------
| PERMISSION |
--------------

Missing Required Dependencies
-----------------------------
error: 'dbus-1-devel' package is missing/incompatible 
error: 'python-gobject2' package is missing/incompatible 
error: 'cups-devel' package is missing or 'cups' service is not running.
error: 'cupsddk' package is missing or 'cups' service is not running.
error: 'cups-devel' package is missing or 'cups' service is not running.
error: 'sane-backends-devel' package is missing/incompatible 
error: 'net-snmp-devel' package is missing/incompatible 
error: 'python3-devel' package is missing/incompatible 
Missing Optional Dependencies
-----------------------------
error: 'avahi-utils' package is missing/incompatible 
error: 'python3-notify2' package is missing/incompatible 
error: 'python3-reportlab' package is missing/incompatible 

ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password: 
|/ Do you want to update repository and Install missing/incompatible packages. (a=install all*, c=custom_install, s=skip):a
Updating repository
-------------------
Installing Missing/Incompatible packages
----------------------------------------
cmd =dbus-1-devel
error: Failed to install 'dbus-1-devel' package, please install manually. 
cmd =python-gobject2
error: Failed to install 'python-gobject2' package, please install manually. 
cmd =cups-devel
error: Failed to install 'cups-devel' package, please install manually. 
cmd =cupsddk
error: Failed to install 'cupsddk' package, please install manually. 
cmd =sane-backends-devel
error: Failed to install 'sane-backends-devel' package, please install manually. 
cmd =net-snmp-devel
error: Failed to install 'net-snmp-devel' package, please install manually. 
cmd =python3-devel
error: Failed to install 'python3-devel' package, please install manually. 
cmd =avahi-utils
error: Failed to install 'avahi-utils' package, please install manually. 
cmd =python3-notify2
error: Failed to install 'python3-notify2' package, please install manually. 
cmd =python3-reportlab
error: Failed to install 'python3-reportlab' package, please install manually. 


Checking Permissions....


Checking for Configured Queues....
warning: Fail to read ppd=/etc/cups/ppd/HP_LaserJet_MFP_M129-M134.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/HP_LaserJet_MFP_M129-M134.ppd
warning: Could not complete Queue(s) configuration check


Checking for HP Properitery Plugin's....
No plug-in printers are configured.

Diagnose completed...


More information on Troubleshooting,How-To's and Support is available on http://hplipopensource.com/hplip-web/index.html

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
John ffitch
Solved:
2019-06-25
Last query:
2019-06-25
Last reply:
John ffitch (jpffitch) said : #1

It seemsthat needsed to download a plugin -- witout knowing it eisted it was hard to debug