Installation failed due to missing dependencies pyqt4-dbus and pyqt4 on Debian 9

Asked by Walter Trepode on 2019-06-20

$ sh hplip-3.19.5.run

I accepted the defaults maked with a '*'.

Is "Debian 9.9" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y

I entered the root password.

I disabled the CD Sources in the apt sources.list (www.deb-multimedia.org) as requested.

At the end the error message was:

error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.

Installer log hplip-install_Thu-20-Jun-2019_12:41:34.log:

hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mHP Linux Imaging and Printing System (ver. 3.19.5)[0m
hplip-install[13656]: info: :[01mHPLIP Installer ver. 5.1[0m
hplip-install[13656]: info: :
hplip-install[13656]: info: :Copyright (c) 2001-18 HP Development Company, LP
hplip-install[13656]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hplip-install[13656]: info: :This is free software, and you are welcome to distribute it
hplip-install[13656]: info: :under certain conditions. See COPYING file for more details.
hplip-install[13656]: info: :
hplip-install[13656]: info: :Installer log saved in: [01mhplip-install_Thu-20-Jun-2019_12:41:34.log[0m
hplip-install[13656]: info: :
hplip-install[13656]: info: :
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: debian-9.9 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.8 version packages.
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mINSTALLATION MODE[0m
hplip-install[13656]: info: :[01m-----------------[0m
hplip-install[13656]: info: :Automatic mode will install the full HPLIP solution with the most common options.
hplip-install[13656]: info: :Custom mode allows you to choose installation options to fit specific requirements.
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mINTRODUCTION[0m
hplip-install[13656]: info: :[01m------------[0m
hplip-install[13656]: info: :This installer will install HPLIP version 3.19.5 on your computer.
hplip-install[13656]: info: :Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mDISTRO/OS CONFIRMATION[0m
hplip-install[13656]: info: :[01m----------------------[0m
hplip-install[13656]: info: :Distro appears to be Debian 9.9.

hplip-install[13656]: info: :
Initializing. Please wait...
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mENTER ROOT/SUPERUSER PASSWORD[0m
hplip-install[13656]: info: :[01m-----------------------------[0m
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mINSTALLATION NOTES[0m
hplip-install[13656]: info: :[01m------------------[0m
hplip-install[13656]: info: :NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mSECURITY PACKAGES[0m
hplip-install[13656]: info: :[01m-----------------[0m
hplip-install[13656]: info: :AppArmor is installed.
hplip-install[13656]: info: :AppArmor protects the application from external intrusion attempts making the application secure
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mRUNNING PRE-INSTALL COMMANDS[0m
hplip-install[13656]: info: :[01m----------------------------[0m
hplip-install[13656]: info: :OK
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mMISSING DEPENDENCIES[0m
hplip-install[13656]: info: :[01m--------------------[0m
hplip-install[13656]: info: :Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
hplip-install[13656]: info: :Package-Name Component Required/Optional
hplip-install[13656]: info: :pyqt5-dbus gui_qt5 OPTIONAL
hplip-install[13656]: info: :libnetsnmp-devel network REQUIRED
hplip-install[13656]: info: :sane-devel scan REQUIRED
hplip-install[13656]: info: :pyqt4-dbus gui_qt4 REQUIRED
hplip-install[13656]: info: :cups-devel base REQUIRED
hplip-install[13656]: info: :reportlab fax OPTIONAL
hplip-install[13656]: info: :pyqt5 gui_qt5 REQUIRED
hplip-install[13656]: info: :libtool base REQUIRED
hplip-install[13656]: info: :cups-image base REQUIRED
hplip-install[13656]: info: :python-notify gui_qt5 OPTIONAL
hplip-install[13656]: info: :xsane scan OPTIONAL
hplip-install[13656]: info: :avahi-utils network OPTIONAL
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mINSTALL MISSING REQUIRED DEPENDENCIES[0m
hplip-install[13656]: info: :[01m-------------------------------------[0m
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing REQUIRED dependency: pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))
warning: Missing REQUIRED dependency: sane-devel (SANE - Scanning library development files)
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mINSTALL MISSING OPTIONAL DEPENDENCIES[0m
hplip-install[13656]: info: :[01m-------------------------------------[0m
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'network': avahi-utils (avahi-utils)
warning: Missing OPTIONAL dependency for option 'gui_qt4': python-notify (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing OPTIONAL dependency for option 'gui_qt5': pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
warning: Missing OPTIONAL dependency for option 'gui_qt5': python-notify (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing OPTIONAL dependency for option 'fax': reportlab (Reportlab - PDF library for Python)
warning: Missing OPTIONAL dependency for option 'scan': xsane (xsane - Graphical scanner frontend for SANE)
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mCHECKING FOR NETWORK CONNECTION[0m
hplip-install[13656]: info: :[01m-------------------------------[0m
hplip-install[13656]: info: :Network connection present.
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mRUNNING PRE-PACKAGE COMMANDS[0m
hplip-install[13656]: info: :[01m----------------------------[0m
hplip-install[13656]: info: :su -c "dpkg --configure -a" (Pre-depend step 1)
hplip-install[13656]: info: :su -c "apt-get install -f" (Pre-depend step 2)
hplip-install[13656]: info: :su -c "apt-get update" (Pre-depend step 3)
hplip-install[13656]: info: :OK
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mDEPENDENCY AND CONFLICT RESOLUTION[0m
hplip-install[13656]: info: :[01m----------------------------------[0m
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libcups2-dev"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y cups-bsd"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y cups-client"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libtool"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libtool-bin"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libcupsimage2"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libcupsimage2-dev"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libsnmp-dev"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y snmp"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y python-qt4-dbus"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y gtk2-engines-pixbuf"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y libsane-dev"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y avahi-utils"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y python-notify"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y python-notify"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y python-reportlab"'
Please wait, this may take several minutes...
hplip-install[13656]: info: :Running 'su -c "apt-get install --force-yes -y xsane"'
Please wait, this may take several minutes...
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mRUNNING POST-PACKAGE COMMANDS[0m
hplip-install[13656]: info: :[01m-----------------------------[0m
hplip-install[13656]: info: :OK
hplip-install[13656]: info: :
hplip-install[13656]: info: :
hplip-install[13656]: info: :[01mRE-CHECKING DEPENDENCIES[0m
hplip-install[13656]: info: :[01m------------------------[0m
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Walter Trepode
Solved:
2019-06-26
Last query:
2019-06-26
Last reply:
2019-06-26

Hi Walter,

 Currently, we have not provided support for Debian 9.9. for work around please manually install these(pyqt4-dbus, Pyqt4) dependency and re-run this installer.

Regards,
Mancikanti Santhosh

Hi Santhosh,

Thank you for your answer!

I solved the problem installing hplip version 3.16.11+repack0-3 with Synaptic Package Manager and everything worked perfectly.

Best regards,

Walter Trepode