HPLIP for debian 9.9

Asked by Eszenyi Peter on 2019-05-31

When will be Debian 9.9 supported?

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Santhosh Manchikanti
Solved:
2019-06-19
Last query:
2019-06-19
Last reply:
2019-06-18
shivani mandora (shivani1708) said : #1

Hi,

We will support Debian 9.9 in future releases.

Thanks,
Shivani

Ernie95 (ernie95ch) said : #2

Good news.
Which timing ? 1 month ? 6 month ? 1 year ?
Just to know it if I can wait or find other solutions (new OS system with VM).

BR

Philip Llewellyn (pllewellyn) said : #3

Hello Shivani, when do you expect the new release of HPLIP which supports Debian 9.9 will be available?

I have Debian 9.9 installed & when I attempt to auto install for Debian 9.8 I get the following dependency errors.
Is there a workaround you could suggest until the new release is available?

Thank you, PL

phil@debian:~/Downloads$ sh hplip-3.19.5.run
Creating directory hplip-3.19.5
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.5 Self Extracting Archive..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.19.5)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Sun-16-Jun-2019_16:44:25.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
-Gtk-Message: Failed to load module "canberra-gtk-module"
\Gtk-Message: Failed to load module "canberra-gtk-module"
error: debian-9.9 version is not supported, so all dependencies may not be installed. However trying to install using debian-9.8 version packages.

Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*): y

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a

INTRODUCTION
------------
This installer will install HPLIP version 3.19.5 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).

DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Debian 9.9.

Is "Debian 9.9" your correct distro/OS and version (y=yes*, n=no, q=quit) ? n

DISTRO/OS SELECTION
-------------------

Choose the name of the distro/OS that most closely matches your system:

Num. Distro/OS Name
---- ------------------------
0 Mepis
1 Debian
2 SUSE Linux
3 Mandriva Linux
4 Fedora
5 Red Hat
6 Red Hat Enterprise Linux
7 Ubuntu
8 PCLinuxOS
9 Linux Mint
10 gOS
11 Linpus Linux
12 Manjaro Linux
13 IGOS
14 Boss
15 Linux From Scratch

Enter number 0...15 (q=quit) ?1

Choose the version of "Debian" that most closely matches your system:

Num. Distro/OS Version
---- ----------------------------------------
0 Unknown or not listed
1 6.0 ("Squeeze")
2 6.0.1 ("Squeeze")
3 6.0.10 ("Squeeze")
4 6.0.2 ("Squeeze")
5 6.0.3 ("Squeeze")
6 6.0.4 ("Squeeze")
7 6.0.5 ("Squeeze")
8 6.0.6 ("Squeeze")
9 6.0.7 ("Squeeze")
10 6.0.8 ("Squeeze")
11 6.0.9 ("Squeeze")
12 7.0 ("Wheezy", Released 04/05/2013)
13 7.1 ("Wheezy", Released 04/05/2013)
14 7.2 ("Wheezy", Released 04/05/2013)
15 7.3 ("Wheezy", Released 04/05/2013)
16 7.4 ("Wheezy", Released 04/05/2013)
17 7.5 ("Wheezy", Released 04/05/2013)
18 7.6 ("Wheezy", Released 04/05/2013)
19 7.7 ("Wheezy", Released 04/05/2013)
20 7.8 ("Wheezy", Released 04/05/2013)
21 7.9 ("Wheezy", Released 04/05/2013)
22 8.0 ("Jessie", Released 04/05/2015)
23 8.1 ("Jessie", Released 04/05/2015)
24 8.2 ("Jessie", Released 04/05/2015)
25 8.3 ("Jessie", Released 04/05/2015)
26 8.4 ("Jessie", Released 04/05/2016)
27 8.5 ("Jessie", Released 27/08/2016)
28 8.6 ("Jessie", Released 22/10/2016)
29 8.7 ("Jessie", Released 22/10/2016)
30 8.8 ("Jessie", Released 31/05/2017)
31 9.1 ("Stretch", Released 22/07/2017)
32 9.2 ("Stretch", Released 7/10/2017)
33 9.3 ("Stretch", Released 9/12/2017)
34 9.4 ("Stretch", Released 10/3/2018)
35 9.5 ("Stretch", Released 10/3/2018)
36 9.6 ("Stretch", Released 10/11/2018)
37 9.7 ("Stretch", Released 23/1/2019)
38 9.8 ("Stretch", Released 16/2/2019)

Enter number 0...38 (q=quit) ?38

Distro set to: Debian 9.8

Initializing. Please wait...

ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password:

INSTALLATION NOTES
------------------
NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.

Please read the installation notes. Press <enter> to continue or 'q' to quit:

SECURITY PACKAGES
-----------------
AppArmor is installed.
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? n

RUNNING PRE-INSTALL COMMANDS
----------------------------
OK

MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name Component Required/Optional
pyqt5-dbus gui_qt5 OPTIONAL
pyqt5 gui_qt5 REQUIRED
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y

INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))

INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'gui_qt5': pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)

CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.

RUNNING PRE-PACKAGE COMMANDS
----------------------------
su -c "dpkg --configure -a" (Pre-depend step 1)
su -c "apt-get install -f" (Pre-depend step 2)
su -c "apt-get update" (Pre-depend step 3)
OK

DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'su -c "apt-get install --force-yes -y gtk2-engines-pixbuf"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
Please wait, this may take several minutes...
Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
Please wait, this may take several minutes...
\Gtk-Message: Failed to load module "canberra-gtk-module"
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK

RE-CHECKING DEPENDENCIES
------------------------
\Gtk-Message: Failed to load module "canberra-gtk-module"
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.
phil@debian:~/Downloads$

Hi Peter,

Work around for debian 9.9 support

Add below line after [debian:9.8] in File location: hplip-3.19.5/installer/distros.dat and run "hplip-3.19.5/install.py" [ if it's fails run again install.py]

# ****************************************

[debian:9.9]

code_name=Stretch

packaged_version=3.19.5

release_date=18/6/2019

same_as_version=9.1

#*****************************************

Regards,
Santhosh

Hi Santhosh,

thank you, this solved the problem.

Regards,
Peter