I have installed hplip-3.19.5 but can't use my printer HP LaserJet Pro MFP m125a as a scanner.

Asked by Luigi Magliocchi on 2019-05-14

I have installed hplip-3.19.5.run.
When I launch it to use the scanner function I get a pop-up window with the following heading: xsane.099 and the following massage: scanning for devices.
Then I get an error window with the following message:
Failed to open device 'HPAIO:/usb/HP_LaserJet_Pro_MFP_M125a?serial=CNB6GC7BDM': error during device I/O.
Then I get another pop-up window with the follwing header: HP Device Manager - Plugin Installer
and the following message:
Driver plug-in required
HP proprietary driver plug-in is missing. Click 'Next' to continue plug-in installation. In case of plug-in download failure, run 'hp plug-in' command from the terminal manually.
When I click 'Next' I get the following error message:
Failed to install plug-in.
Either you have chosen to skip the plug-in installation, or entered incorrect password.
When I run hp-plugin from the terminal I get the following text lines:

HP Linux Imaging and Printing System (ver. 3.19.5)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

HP Linux Imaging and Printing System (ver. 3.19.5)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Gtk-Message: 11:22:59.487: Failed to load module "canberra-gtk-module"
Checking for network connection...
Downloading plug-in from:
Plugin is not accessible. Trying to download it from fallback location: [https://developers.hp.com/sites/default/files/hplip-3.19.5-plugin.run]
Receiving digital keys: /usr/bin/gpg --homedir /home/luigi/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9

Then a pop-up windows tells me that it's impossible to receive the key from the key server and asks me if I want to install the plug-in anyway.
When I click 'yes' I am prompted to input my superuser password.
 After this I get the error message:
Plug-in install failed.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-05-14
Last reply:
2019-05-15
Anton (korlatyanu) said : #1

have same issue..

Hi Luigi,

Please download the "hplip-3.19.5-plugin.run " plugin from below location and run "sh hplip-3.19.5-plugin.run" in the terminal to install the plugin

https://developers.hp.com/hp-linux-imaging-and-printing/plugins

Regrads,
Santhosh

Can you help with this problem?

Provide an answer of your own, or ask Luigi Magliocchi for more information if necessary.

To post a message you must log in.