HPLIP support for HP Scanjet Pro 2500 f1 on OpenSuse

Asked by Richard Pace on 2019-05-04

Hi:
I've been waiting for HPLIP to support HP Scanjet Pro 2500 f1 and finally with Hplip 3.19.3 it does, except not on Linux OpenSuse distributions. Why is that and do you expect a remedy for OpenSuse soon? Thanks.
Richard Pace

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-05-19
Last reply:
2019-05-27
shivani mandora (shivani1708) said : #1

Hi Richard,

HP Scannjet Pro 2500 is supported on OpenSuse distribution in 3.19.3 release.
Please check release notes for the same.

Thanks,
Shivani

Richard Pace (loml25rfl) said : #2

Hi:
This is from 3.19.3 release notes:

Product HP ScanJet Pro 2500 Limitations:

  HPLIP does not support HP ScanJet Pro 2500 f1 device on OpenSuse Linux distribution.

So my question still remains, why is HP ScanJet Pro 2500 not supported
on OpenSuse Linux distributions, and is there a remedy coming??? (and
I've tried:?? HPLIP does not recognize the device even with manual USB
address setting from LSUSB,?? LSUSB shows the device as - Bus 002 Device
011: ID 03f0:6005 HP, Inc )

Thanks,
Richard
On 5/6/19 1:33 AM, shivani mandora wrote:
> Your question #680630 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/680630
>
> Status: Open => Answered
>
> shivani mandora proposed the following answer:
> Hi Richard,
>
> HP Scannjet Pro 2500 is supported on OpenSuse distribution in 3.19.3 release.
> Please check release notes for the same.
>
>
> Thanks,
> Shivani
>

shivani mandora (shivani1708) said : #3

Hi ,

The release note you mentioned is from 3.19.1 release notes. We have already provided HP SannJet Pro 2500 f1 device on OpenSuse in 3.19.3. Please download latest hplip driver and after installing driver, also install plugin file with run file. Scanner should work fine.

Thanks,
Shivani

Richard Pace (loml25rfl) said : #4

Sorry to bother.  HP-SETUP still does not find the device.  I wonder if
it's because I'm running SuSe Tumbleweed?  HP-CHECK gives these messages:

warning: 3-20190516 version is not supported. Using 3-15.0 versions
dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

  Kernel: 5.1.2-1-default #1 SMP Tue May 14 18:21:06 UTC 2019 (08094c3)
GNU/Linux
  Host: linux-nab9
  Proc: 5.1.2-1-default #1 SMP Tue May 14 18:21:06 UTC 2019 (08094c3)
GNU/Linux
  Distribution: 3 20190516
  Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.19.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 3
distro  20190516 version

On 5/7/19 10:32 PM, shivani mandora wrote:
> Your question #680630 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/680630
>
> Status: Open => Answered
>
> shivani mandora proposed the following answer:
> Hi ,
>
> The release note you mentioned is from 3.19.1 release notes. We have
> already provided HP SannJet Pro 2500 f1 device on OpenSuse in 3.19.3.
> Please download latest hplip driver and after installing driver, also
> install plugin file with run file. Scanner should work fine.
>
>
> Thanks,
> Shivani
>

Hi ,

ScanJet 2500 will not be listed as part of hp-setup.
Please use hp-scan command line option or hp-uiscan to launch the UI.
ScanJet 2500 will be detected in hp-scan and hp-uiscan.

Thanks,
Umesh

Can you help with this problem?

Provide an answer of your own, or ask Richard Pace for more information if necessary.

To post a message you must log in.