There was a problem opening the file “/home/loricarnahan/Downloads/hplip-3.19.3.run”.

Asked by Lori Carnahan on 2019-04-07

There was a problem opening the file “/home/loricarnahan/Downloads/hplip-3.19.3.run”. I saw a response in the Q&A that was suggested to me. I attempted it and it won't run I can't even get the hplip-3-19-3 to complete. Please be gently. I am not a programmer, developer, or a business. I'm very frustrated and scared I'll have to return my printer over this not working.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-04-07
Last query:
2019-04-07
Last reply:
2019-04-07
Lori Carnahan (loricarnahan) said : #1

The error says the file you opened has some invalid characters, if you continue editing this file you could corrupt this document.

I haven't edited anything. Something is really wrong. I am using Ubuntu 18.04.

Lori Carnahan (loricarnahan) said : #2

I even tried to load 3.16.7 I am getting the same error.

Best Manfred Hampl (m-hampl) said : #3

How do you "open" the installer file? A doubleclick probably does not perform the right action.

see https://developers.hp.com/hp-linux-imaging-and-printing/install/install/index for details:
open a terminal window and issue the command
cd Downloads
and then issue the command
sh hplip-3.19.3.run

Lori Carnahan (loricarnahan) said : #4

Thanks Manfred Hampl, that solved my question.