plugin installation fails - error: Python gobject/dbus may be not installed - hp-check says all ok - SuSe Leap 42.1

Asked by Michael Nagler on 2019-02-18

Hello,

When I use hp-plugin, it quits with an error:
error: Python gobject/dbus may be not installed
error: Plug-in install failed.

This prevents me from using the scanner-function of the LaserJet Pro MFP M281fdn. What can I do?

What I did:
I use a LaserJet 1010 for some time, now I got a LaserJet Pro MFP M281fdn.
I downloaded HPLIP 3.19.1 for Suse from https://developers.hp.com/hp-linux-imaging-and-printing/gethplip
and it installed it flawlessly. Printing is ok.

When using skanlite, I was instructed to run hp-plugin first, which I did, creating the above mentioned error.

hp-doctor, said phyton-notify was missing, but was not able to install it. I installed it with Yast.
Now hp-check shows no errors or warnings any more (is it ok to copy-paste it at the end?)

I have python2.7 and python3.4 installed.
Among the installed packets, I can find these:
dbus-1-python
dbus-1-python3
python-gobject
python-gobject2
python-gobject3
so that does not look to bad to me.

I have not much of an idea any more. When I ran hp-setup, he asked to replace the ppd-file for the LJ1010. Afterwards this printer does not work any more ("Filter Fails"), printer output says:
PCL XL error
subsystem: Kernel
Error: Illegal Tag
Operator: 0x1b
Position: 8
but that is probably a different problem

openSuse Leap 42.1

Thank you for your help!

 Michael

--------------------------------
hp-check -r output:

Saving output in log file: /home/internet/hp-check.log

HP Linux Imaging and Printing System (ver. 3.19.1)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.12.2-3.g8db850a-default #1 SMP PREEMPT Tue Jul 18 12:50:30 UTC 2017 (8db850a) GNU/Linux
 Host: michael-tuxedo
 Proc: 4.12.2-3.g8db850a-default #1 SMP PREEMPT Tue Jul 18 12:50:30 UTC 2017 (8db850a) GNU/Linux
 Distribution: 3 42.1
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.19.1
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for suse distro 42.1 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.19.1

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/HP
ppdbase=/usr/share/cups/model
doc=/usr/share/doc/hplip-3.19.1
html=/usr/share/doc/hplip-3.19.1
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.19.1
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = false
last_upgraded_time = 1550325835
pending_upgrade_time = 0
latest_available_version = 3.17.10

[installation]
date_time = 02/18/19 21:12:19
version = 3.19.1

[last_used]
device_uri = "hpaio:/usb/HP_ColorLaserJet_MFP_M278-M281?serial=VNBNL301TH"
printer_name =
working_dir = /home/internet/\xd6\x66\x66\x65ntlich/HPLIP/hplip-3.19.1-plugin.run

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------
| COMPILEDEP |
--------------

 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 4.8.5 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.0 OK -
 libtool libtool - Library building support services REQUIRED - 2.4.2 OK -

------------------------
| General Dependencies |
------------------------

 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.1 OK -
 python-xml Python XML libraries REQUIRED - 2.1.1 OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
 sane-devel SANE - Scanning library development files REQUIRED - 1.0.24 OK -
 pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.4 OK -
 libpthread libpthread - POSIX threads library REQUIRED - 2.19 OK -
 python-devel Python devel - Python development files REQUIRED 2.2 2.7.12 OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 1.7.5 OK -
 python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.0 OK -
 cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
 reportlab Reportlab - PDF library for Python OPTIONAL 2.0 2.7 OK -
 pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 1.7.5 OK -
 python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.12 OK -
 python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 sane SANE - Scanning library REQUIRED - 1.0.24 OK -

----------------------
| Scan Configuration |
----------------------

 scanext Scan-SANE-Extension REQUIRED - 3.19.1 OK -
 hpaio HPLIP-SANE-Backend REQUIRED - 3.19.1 OK 'hpaio found in /etc/sane.d/dll.conf'

-------------------------
| External Dependencies |
-------------------------

 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.15 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.24 OK -
 cups CUPS - Common Unix Printing System REQUIRED 1.1 1.7.5 OK 'CUPS Scheduler is running'
 network network -wget OPTIONAL - 1.14 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.113 OK -
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.998 OK -
 dbus DBus - Message bus system REQUIRED - 1.8.22 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.31 OK -

---------------------
| Python Extentions |
---------------------

 hpmudext IO-Extension REQUIRED - 3.19.1 OK -
 cupsext CUPS-Extension REQUIRED - 3.19.1 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/HP_ColorLaserJet_MFP_M278-M281?serial=VNBNL301TH' is a Hewlett-Packard HP_ColorLaserJet_MFP_M278-M281 all-in-one

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI Model
  -------------------------------------------------------- --------------------------------------------
  hp:/usb/HP_ColorLaserJet_MFP_M278-M281?serial=VNBNL301TH HP ColorLaserJet MFP M278-M281
  hp:/usb/hp_LaserJet_1010?serial=00CNFD255692 HP LaserJet 1010

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP_ColorLaserJet_MFP_M278-M281
------------------------------
Type: Printer
Device URI: hp:/usb/HP_ColorLaserJet_MFP_M278-M281?serial=VNBNL301TH
PPD: /etc/cups/ppd/HP_ColorLaserJet_MFP_M278-M281.ppd
PPD Description: HP ColorLaserJet MFP M278-M281 Postscript (recommended)
Printer status: printer HP_ColorLaserJet_MFP_M278-M281 is idle. enabled since So 17 Feb 2019 21:31:04 CET
Communication status: Good

HP_ColorLaserJet_MFP_M278-M281_fax
----------------------------------
Type: Fax
Device URI: hpfax:/usb/HP_ColorLaserJet_MFP_M278-M281?serial=VNBNL301TH
PPD: /etc/cups/ppd/HP_ColorLaserJet_MFP_M278-M281_fax.ppd
PPD Description: HP Fax hpcups
Printer status: printer HP_ColorLaserJet_MFP_M278-M281_fax is idle. enabled since Sa 16 Feb 2019 15:07:24 CET
Communication status: Good

hp_LaserJet_1010
----------------
Type: Printer
Device URI: hp:/usb/hp_LaserJet_1010?serial=00CNFD255692
PPD: /etc/cups/ppd/hp_LaserJet_1010.ppd
PPD Description: HP LaserJet 1010, hpcups 3.19.1
Printer status: printer hp_LaserJet_1010 is idle. enabled since So 17 Feb 2019 21:59:10 CET
Communication status: Good

--------------
| PERMISSION |
--------------

USB HP_ColorLaserJet_MFP_M278-M281 Required - - OK Node:'/dev/bus/usb/001/005' Perm:' root lp rw- rw- rw- rw- r--'
USB hp_LaserJet_1010 Required - - OK Node:'/dev/bus/usb/001/002' Perm:' root lp rw- rw- rw- rw- r--'
No errors or warnings.

Done.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Nagler
Solved:
2019-02-22
Last query:
2019-02-22
Last reply:
Michael Nagler (glich) said : #1

It did work when I downloaded the plugin "hplip-3.19.1-plugin.run" file from the below path and used "sh hplip-3.19.1-plugin.run" command instead of running hp-plugin. For whatever reason.

https://developers.hp.com/hp-linux-imaging-and-printing/plugins